Raspberry Pi Camera Module - * No Cameras Available *

Hi there, I have connected the wide angle camera module to the Raspberry Pi 4 4Gbp model, and also the PIR Motion Sensor, as described from multiple sources on the internet, and from the Beginner’s Guide book. I have also run sudo raspi-config and ensure that everything is enabled. But when I run libcamera-still -o image.jpg I keep getting the same message.
No Cameras Available. I have checked to make sure it is seated properly, and it looks fine and won’t go in any further, and is secured.
I don’t know what else to do. Could the camera itself be faulty? Or could the PIR Motion Sensor be interfering with it?

Any help would be appreciated. I have included some images.

Kind regards


1 Like

Hey Roger,

We have seen a few issues lately with the cameras. One thing we have found fixes it is flashing a new OS onto your SD card and updating/upgrading, from there reintroducing the apps and things you have on the pi to check if there is a conflict at any point with one of the installed apps.

I cant imagine there would be an issue with the PIR sensor, that should work fine, but a stray app or something on the Pi could be causing this issue that makes it incompatible with the camera module.

We don’t know if its just an issue with the latest update to Pi OS (3rd May), but we are looking at what the issue may be and a fix for it.


1 Like

Thanks Blayden, as soon as I installed Microsoft Studio Code, and ran some code, it can’t find the camera again. I flashed the OS, and started a fresh, and was able to get a test image using libcamera-still, but as soon as I installed Studio Code and ran the code, it broke. I’m trying to do an assignment for the Certificate IV, and I need this to work, so I need Studio Code and my Python script to work.
I’m going to fail this assignment if I can’t get this to work.

If you have connected the camera module to the Raspberry Pi 4 correctly, enabled the camera interface using sudo raspi-config, and still receive the “No Cameras Available” error, there are a few troubleshooting steps you can try:

  1. Check the camera connection: Ensure that the camera module is properly connected to the camera port on the Raspberry Pi. Make sure it is inserted correctly and securely. Double-check the orientation and alignment of the ribbon cable.

  2. Verify camera detection: Run the command vcgencmd get_camera in the terminal to check if the camera is being detected by the Raspberry Pi. You should see either “supported=1 detected=1” or “supported=1 detected=0”. If it shows “detected=0”, it suggests a connection or compatibility issue.

  3. Test with a different camera: If possible, try using a different camera module (known to be working) with your Raspberry Pi to confirm if the issue lies with the camera module itself or some other configuration issue.

  4. Check camera settings: Review the /boot/config.txt file to ensure that there are no settings conflicting with the camera operation. Look for any lines starting with start_x or gpu_mem and make sure they are not commented out.

  5. Power supply and current limitations: Ensure that your Raspberry Pi is powered by an adequate power supply. Insufficient power can sometimes cause issues with camera detection. Additionally, if you have other power-hungry devices connected to the USB ports, it may be worth disconnecting them temporarily to see if it resolves the issue.

  6. Disable the PIR Motion Sensor temporarily: To eliminate the possibility of interference, try disconnecting the PIR Motion Sensor temporarily and see if the camera starts working. If it does, it might indicate a conflict between the camera and the PIR Motion Sensor. In such cases, you may need to review the GPIO pin configuration and ensure they do not overlap.

Hi Roger,

We’ve tried to retrace your steps and replicate the issue you are having. So far we’ve flashed a fresh image of Raspberry Pi OS and then installed visual studio code here and our camera seems to still be working.
Can you please let us know the exact OS version you are using and the order in which you’re installing each program? If you can give us the version number and link us to all the apps you’re installing we can hopefully reproduce the issue here.

We don’t yet know the exact cause of the issue, but it could be related to some packages accidentally being marked as superfluous and removed when one package installs if the dependencies aren’t yet set right for the new Raspberry Pi Camera module V3.

There was a similar issue when the Bullseye version of Pi OS launched that stopped some cameras from working with the Pi 3 boards because the firmware dependencies weren’t all listed so packages were missing and would need to be manually installed. Incomplete dependencies almost seem to be a Linux tradition sometimes.