Raspberry pi zero w usb wont work

Hi i have tried to add a number of usb keyboards mice and a remote to the center micro usb.

But nothing happens i recivied two Of these as a gift for my birthday and they have never worked since i got them i know my friends bought them from here so i have conceeded defeat and looking for help with this issue

1 Like

Hi Darren

Is this issue happening the same on both of the Pi’s? Are you using an otg cable between the Pi and the keyboard?

Yes i do have a otg cable connect i also tried a clipsal usb mech but still nothing

Hi Darren,

To give me a better idea of what is happening can i get you to post a photo of how you have everything setup?

1 Like

please find attached image

I have noticed the indicator light appears off in the picture, to clarify, you plug it in and it powers up and loads Raspbian but you do not have use of the keyboard and mouse, or is it not powering up at all?

Yes it powers up i have switched from openelec to raspbarian to liberelec and still no mouse keyboard or even my kodi remote

No usb works

That looks like a non-standard power cable. Is there any chance that the PSU it is not providing enough juice? Some phone chargers are actually rather low-spec. It is also not uncommon for a poorly-made cable to limit the voltage. e.g. The Pi board prefers a 5.1V PSU, while some phone chargers output 5V and this can drop to < 5V when the length of your cable is factored in.


Just to be sure that the problem is on the Pi side of the equation, did you have another OTG cable to test it out with?

I have tryied 2 pi’ with 3 otg cables and a clipsal data mech and my power supplr for my pi 3b+ along with my google home mini power supply.

Still not working so i have orded 4 power supplys to make sure.

1 Like

Let us know how the new supplies go. When debugging a problem like this I try to find the common factor that could be causing the problem, but you seem to be getting the same behaviour despite changing all of the parts. The only thing I can think of that you have not changed is the SD card (I’m not sure why that would affect the keyboard, but stranger things have happened).

1 Like

It is possible the SD card could affect things, if it’s forcing the Pi into device mode rather than host mode. This usually only happens when you use the Ethernet-over-USB or Serial-over-USB stuff though, by changing the /boot/config.txt and /boot/cmdline.txt files.

I changed sd card still not working it will be a few weeks or so before the new power supplys turn up

1 Like

I’m having the same trouble with a Pi Zero W that I received earlier this week.

In my case I am using the official Pi power supply and official SD card with the latest Rasbian Stretch flashed on to it, and for the life of me can’t get it to detect any devices when using the OTG cable that came with the Starter Kit.

Some devices when plugged in are causing the Pi Zero W to completely lock up, others, such as a USB keyboard just do nothing, with no sign of anything in dmesg or lsusb either.

Edit: Also tried a different power supply and OTG cable, just to rule those out.

Edit 2: I just tried the original OTG cable that came with the Starter Kit with my Android phone, and it doesn’t work. My other OTG cable that I had lying around does work with the Android phone though. Is it possible the original OTG cable that came in the Starter Kit may be faulty and has damaged the USB port on the Pi Zero W?

Edit 3: Interestingly I am now seeing something (though not what I’d expect) in dmesg when booting with the OTG cables and a USB thumb drive already connected:

[   58.483012] Indeed it is in host mode hprt0 = 00021d01
[   58.692948] usb 1-1: device descriptor read/64, error -110
[   73.923003] Indeed it is in host mode hprt0 = 00021d01
[   74.132949] usb 1-1: device descriptor read/64, error -110
[   74.253082] usb usb1-port1: attempt power cycle

Still no luck getting devices to appear in lsusb with it though. I also get nothing in dmesg if I insert the cable or device after booting.

You guys seem to be having similarish problems with the OTG cable, so let’s try taking that out altogether by testing just the Pi USB port. I need you to edit a few files on the MicroSD card, so put it in a different computer or edit it over SSH if you have that access.

/boot/config.txt: At the end, put dtoverlay=dwc2
/boot/cmdline.txt: Change rootwait to rootwait modules-load=dwc2,g_ether
If you don’t already have SSH enabled, create a blank file as /boot/ssh (no extention)

If you use a Windows computer, check to see if you have the Bonjour Service listed under Services in Task Manager, if not you can get it here. Linux and Mac should already have it.

Then put that card back into your Pi Zero, and without using an external power supply, plug a Micro USB cable between the USB port in the centre of the board and another computer. Wait for the Pi to boot up, and it should be detected by your other computer. You should then be able to SSH into it using raspberrypi.local as the address if you haven’t changed the hostname (if you have, it’s just .local on the end of your hostname).

If all goes well, you know your USB port isn’t dead, and the problem is with the OTG cable. If not, we’ll have to look further at the Pi.

1 Like

Thanks for your reply Josh, I have just discovered that two of the pins on the USB-A connector on the original OTG cable have been pushed back, shorting out against the outer shell. So that likely confirms the OTG cable is broken. I’m not sure if I caused this damage or not.

Regarding the Pi Zero W, no luck with getting it to appear as an Ethernet device on my computer. The computer powers the Pi Zero W OK via USB, but no new USB device appears on the computer for the Ethernet device. I have a feeling the shorted out OTG cable has caused damage to the Pi Zero W.

I dont have root wait,

Windows hasnt found them either so for me must be the devices…

1 Like


Do you have Raspbian installed, or is that another OS? And which version?

it was OpenELEC-RPi.arm-8.0.4 for the pi zero now i have just made a new sd card with 2018-06-27-raspbian-stretch