Zero wh - usb port dead?

Hi everyone!

The usb port on my Pi Zero WH seems dead. I’ve searched around for similar issues and done some debugging, but wondering if anyone would have any more ideas on what to check before I declare it dead?

First of all, when I boot the pi, and then connect the OTG cable and check ls /dev/, then no new device appears. When I also connect a memory stick to the OTG, then also no new device appears. Similar, when I check dmesg -w before connecting the OTG & the stick, nothing new appears, and also no new devices in lsusb.

Then ofc the question is, could there be something wrong with my software or hardware, i.e., the sd card, power supply, OTG or the memory stick? Now I happen to have a second pi around. This one is a Zero W, and not WH, so no headers, but my understanding is that otherwise, it’s the same board. So I plugged in the same sd card, power supply, OTG and memory stick to this Zero W, and it is working, i.e., here, I do get new devices, both in ls /dev and lsusb, when plugging in the memory, and I do get additional output in dmesg.

Since the exact same software and hardware is working on the Zero W pi, but not on the Zero WH, I’m inclined to think that it’s a hardware fault in the WH. Do you have any ideas on what more I could check?

Just to align on how I’ve hooked things up, I’m attaching pics, both for the non-working Zero WH:

and the working Zero W:



Hi Mac
Firstly make sure you are using a USB Data cable. I have been caught. Some of these USB cables with a micro connector are “charge only” and have only got the 2 power wires in them.
Cheers Bob


Hi Mac, can you try connecting the Zero WH to PC or another Pi non-headless, via the USB port and try to see it on the other computer?
If the USB port in the WH is not working it will not be recognized.


Thanks for your hints!

@Robert93820, the cable I used is an OTG cable, so yes, it is a data cable. What I think confirms it is that the cable works correctly when I hook it in to my working Zero W pi. Have a look at the pics in my original post to see how I connected things.

@G177630, you mean the gadget mode, right? I tried it out. I followed this guide: Connect to a Raspberry Pi Zero W Via USB - No Mini HDMI Cable Needed : 4 Steps (with Pictures) - Instructables

When powered up my pi WH by connecting the usb data cable, my pc does not react to the pi at all. See below pic of how I connected the two, along with an empty dmesg -w in the background:

And again, the corresponding thing works when I try it with the same setup, but with my working Zero W instead. With the Zero W, my pc’s dmesg recognises the device as a “RNDIS/Ethernet Gadget”, but not with the Zero WH unfortunately.

Any more ideas?


Only thing I could think of is to examine the soldering of data pins under a magnifier. But if this is new and can be returned for replacement, it would be the best.

I did check for continuity between the usb port and the test pads that can be found on the back of the board, as per the image found e.g. in this post: pi zero w test pads for extra USB [solved] - Raspberry Pi Forums , and all the connections are fine and the same on both the pi with the working, and the non-working usb port. So att least the soldering of the usb port itself is fine, the issue seems to be deeper than that.

Any idea how I can arrange for a replacement? I’m new to Core-Electronics processes. :slight_smile:

Someone from Core should be able to help you Mac.

Ok, many thanks for your help!


Hi Mac,

Sorry to see you have a faulty Pi Zero there but thanks for the troubleshooting you’ve already done.
We handle our RMA process via email so to get this one replaced shoot us an email and include a link to this forum thread so we can quickly get up to speed. Then we should be able to look at getting you a replacement Pi.

1 Like

Hi Trent,

Thanks for the prompt reply! I reached out on email, and me and Bryce are already on it. Thanks much! :slight_smile: