Core Electronics Forum

Retro Games Arcade image setup for Raspberry Pi4 or 3B+

I’m editing this first post, to clarify things, and make the forum easier to follow in future:

Hey guys, I have 2 duplicate arcade systems, a bartop arcade (mini arcade machine) and a arcade stick which plugs into any tv etc, with an HDMI cable see pictures below. They are currently running with a Raspberry PI3B+ with a working arcade image called Hyperpie 2. It is a bootable image, which starts up when the Pi is turned on. The Hyperpi 2 image is an updated version of an image, which runs reptropie and retroarch emulators, and works with Emulation station front end (i.e. the pretty user interface), in Attract mode. If you zoom in on my bartop arcades screen, you will see a few things it runs. Both my arcade stick, and my bartop arcade are the same, the run with the Raspberry pi 3B+ and have a Xinmotek arcade dual arcade controller, and chipboard.

I didn’t want to keep taking my Raspberry pi, out of my arcade machine, and plugging it into my controller when i want to play on the tv, or take it to a friends house, so I bought another (a second) Raspberry Pi 3B+ which didn’t work (long story)
Both my bartop arcade, and my controller stick works with my raspberry pi 3B+ and the bootable image on the SD card.

So i bought a new Pi4 the other day, but my image is not booting up, so I’m asking for help. I just ordered another 3B+ today, because i just want this thing to work, so hopefully I can just stick in the sd card with the image, and it will work, like the one in my arcade now.

But if someone can help me figure out how to get this PI4 working with the image, that would be great. If you help me get this thing working I am happy to share the image with you, so YOU CAN HAVE YOUR OWN ARCADE. Once it’s set up, it simply a matter of copying the image, and popping it into your raspberry pi, and you can have your own arcade machine.
A REAL PRACTICAL SOLUTION ON THIS WOULD BE MUCH APPRECIATED, i.e I’m located in Collaroy (Sydney northern beaches), and am willing to travel to Newcastle to set it up, if need be, we can open up the image if need be, update it, sort it out in a matter of an hour, and then it’s done! I would like to get this fixed, because it would also be a nice thing for you guys to be able to share in, and I am more than happy to make it available if i am allowed, as a games device.

When i tried booting my new PI4, it gave me the error messages below. My understanding is that there is no operating system on the PI 3 or 4 itself, the boot program is in the micro SD, so I’m not sure why it doesn’t simply boot up from the disk, unless something’s changed from the PI3b+ to the Pi4.




arcade stick

3 Likes

Hey Jasen,

Indeed things have changed from the 3 to the 4 - it uses different hardware. Here’s your clue:

The older linux kernels don’t include the drivers needed to work on the Pi 4. You just need to update your OS.

When you say the controllers didn’t work, what are the controllers? How are they hooked up?

I did a bit of searching and I can’t find anything on Hyperpie past 2018 (4 years ago now). Looks to me like it’s dead. Retropie is pretty popular, super easy to setup and very stable. I’d recommend trying it out instead.

2 Likes

Hi Oliver, I will try to edit my post, so that it is user friendly. I’m very new at this. Please re-read my post, as i have changed most of it, to also address your questions and our misunderstanding. I took a picture of my arcade controller for you, it got a pi, and xinmo chip in it, I don’t use the pi with a operating system, like windows, which runs it’s own programs on it. It is a bootable games card, which runs hyperpi 2, which includes retropie. It boots up like an old arcade machine. When you switch it on, it boots up straight into the program, which is basically the emulation station front end, giving you a list of arcade and other consoles, which you can then navigate into the games.

The controller and sd card image works on my PI3b+. I just need another one, because i have 2 arcade machines, one being the bartop, the other just a more mobile controller.

Both work, but at the moment, i only have one computer (the pi), to share, so i have to plug one out and put into the other, depending on which one i want to use. I bought the PI 4 the other day, after talking to one of the sales, guys, and he said that I would probably be able to put my SD card in like the PI3 B+, and it should work but it doesn’t. I ordered another 3B+ today, to hopefully resolve this, but this PI4, is a much better computer, and i would like to see, if I can get it to run the boot disk.

From what you said, it seems like i need to open up the image, and gain access to what’s inside of it, and update the drivers relating to the PI 4. I don’t even know whether this thing has an operating system on it, or how to find it. I dont know where to begin with this,
as the boot image does not come up as readable on if i had to plug it into an sd card reader on windows.
Just to make sure we are on the same page, the PI itself doesn’t have any memory or disk on it, so i can’t update the pi, it;s the boot image i need to access and update, in order to make it work on the pi4?

1 Like

Hi Jasen,

All raspberry Pi’s require an operating system to work. 99% of Pi’s run a variant of Linux, including yours by the sounds of it.

Retropie actually runs on Raspberry Pi OS (formerly Raspbian), which itself is a variant of Debian Linux. Retropie isn’t actually an emulator, but an SD card image which includes a bunch of different software, including a few emulators, all bundled together in a neat package.

I’ve done a bit of reading, and indeed, the most recent update of Hyperpie is from Sep 2018:

As best I can tell, Hyperpie is an image based on Retropie (and Hyperspin) which includes a heap of artwork, video files, and some extensive customisation of emulation station (hence the extra 50GB of data).

There’s no apparent reason an image which works on one Pi 3B+, shouldn’t work on another 3B+ though.

When you say the controller didn’t work - what exactly do you mean? I found the homepage for it and there’s an article on configuring it in the Retropie docs:
http://xinmotek.com/index.html

It’s just a USB-HID interface, so shouldn’t be too difficult. There is a setting that needs to be changed in some config files so it is recognised as 2 separate controllers though.

As for getting it working on a Pi 4, I’d suggest you make a copy of the SD Card, then boot it up on the 3B+. Exit out of emulation station to the command line. Connect it to the internet (an ethernet cable’s probably easiest rather than mucking with WiFi). Then type:
sudo apt-get update
sudo apt-get full-upgrade

This will update your OS on your SD card. Once it finishes downloading and installing everything, you should then (fingers crossed) be able to use it with your Pi 4.

2 Likes

I’ve just received my new PI 3B+. It’s identical to the Working PI3B+ in my current working arcade machine. This new PI 3B+ doesn’t work properly, and it’s doing exactly the same, as the last 3B+ that I had, which I threw out because I thought it was not working. It has the same issue as the one i threw out. So it seems somehow, there is something that is in the new 3B+, that’s not working properly.

There is nothing wrong with my arcade sticks - both work fine, on my working PI3B+.
When I use the NEW (not working - Ill call it) Pi3b+, the image loads fine (I’m using the same micro SD card, I’m only using the one micro SD card), the image loads, but i can only navigate with the joystick, and one of the buttons reads (ie. it performs the configured function it was set up to do), the other buttons don’t, so i can’t get into the menu. Somehow it’s not recognizing the buttons. Like I said before, I don’t know how to make it clearer - the buttons work fine on the other WORKING pi, with the same SD card. It’s the same card, so the only thing that doesn’t work, is the PI.
{For clarity - When you use the working PI, the joysticks (on both machines) and every button on the Xinmo, has been set up, and configured correctly. Which means when you test it in Windows, each item reads correctly, and it is setup correctly as a dual controller stick.
When you play the image on both machines, the image is correctly configured, so when you load it, and play it on the PI, you are able to navigate through the interface (with the buttons and joystick) navigate menus, enter and exit games, and consoles, and play games. It’s all set up and configured to do that properly and it works with both my arcade, and the separate control stick unit (using the working PI3B+). I want to simply get another PI3B+ but they don’t seem to be working properly, as described, it should simply be a matter of plugging it in, and inserting the SD card}

Why is one PI working, and the other same Pi not working properly. Can you please clarify the following for me - there is NOTHING on the PI itself. It’s not like i can preload the PI, or change something, on it, and then take out the setupSD card, swap it for this image, and it will work, because the PI itself doesn’t store any info on it, it works from the info on the disk you have in it - is that correct? Once you take out a SD card on a PI, the PI itself, is like a simple piece of harware, it doesn’t have any software built into it?

That’s the issue, one PI3b+ works, the other 3B+ doesn’t. If i had know that, I would probably have kept the other one to fix, i just thought it was faulty. It’ would be a great start to just get the Pi3B+ to work for now, because at least that image is loading. Let’s hold off on the PI4, until i can get the 3B+ working.

1 Like

Hi Jasen,

The only thing to my knowledge that the Pi holds onto between SD cards are the very basics, like files needed to boot, and the Linux kernel, and video drivers. (Info here: GitHub - raspberrypi/firmware: This repository contains pre-compiled binaries of the current Raspberry Pi kernel and modules, userspace libraries, and bootloader/GPU firmware.)

Any software bugs should follow around your uSD card.

Since your Xinmo runs on USB, I would think it’d either work or not, instead you have one functioning button, which is confusing me a bit. Maybe some of our retropie gurus can jump in here? I’m a little over my head here without personal experience of the Xinmo

-James

Just to clarify, have you tried reconfiguring the joysticks on the new Pi? Or are you expecting a literal plug and play?

Your new Pi obviously is not 100% identical, as all hardware will have unique identifiers (this is what allows you to use 2 of the same anything on one machine).

As I found above, those controllers your’e using are a bit weird and require some special configuration in retropie.

Have you tried wiping the controller configuration?

Ps. If you’ve still got that ‘broken’ Pi, I’ll gladly take care of it for you :wink::smile:

1 Like

Hey Jasen,

Thanks for posting on the forum, unfortunately as this is a public forum and questions are not specifically directed to Core Electronics staff we don’t allow the sharing of personal contact information in posts.

I’ve removed it from your post for your protection and hidden the edits if you’re wondering why the message has changed slightly. If you have any questions please let us know.

3 Likes

I was expecting or hoping for a literal plug, and play, because it was my understanding that the machines, are identical, and that they have nothing on them, so i expected to be able to put in my same sd card, and thereby have a plug and play device:) So, if one Pi’s working, how do i get the other Pi the same? I am going to have to learn how to access the device and see if i can reset the controller config, for that device. I don’t know how to do this, so i need to learn how.
If I dont get it to work, i would gladly send it your way. lol , i just got told i can’t put personal info down. i was hopeing to send it to someone, so they could get it work, and then simply put down a summary post forum on how it was done, saving us, the time, and effort, and all the extra grey hair. Why can’t i simply, just get another device, which will work, lol, is that too much to ask for:)

1 Like

Could it be, that the linux kernel or something, is different between the devices. and is causing this issue. I wouldnt have a clue, whether one could access and write over them, if they are build in, and even if you could, would it work , if they machines are different? Oliver suggested i may need to relook at the config files on the sdcard, i would first need to learn how, and then find out how to access, and overwrite it. Perhaps the maker of my machine, can help me with that.
yeah, in the “Faulty pI” the joystick works, allowing me to scroll up and down, and at least one or two buttons work, but the button that functions as an “ENTER”, into the submenu’s and games doesnt respond. If i could get into the games, i could at least see, if the back buttons, and other bottons in the games work as well, but i can’t see that from where i am, so it just appears that the joystick, and one or two others are working.

1 Like