Retropie - Nespi 4 Setup (no boot)


Im having issues setting up my Nespi 4 console. Have flashed Retropie OS 4/400 to micro SD card but the system doesnt boot when SD card is inserted - red light blinks for a second and noting happens other than the fan engaging

When I remove SD, the nespi boots noting SD card not detected.

I have tried on two micro SD cards with the same outcome.,

Hi Nathan,

Which version of Pi are you using? Which software are you using to flash Retropie to your SD Card - I’d recommend using the Raspberry Pi Imager as it’ll take care of downloading the image as well as flashing your SD card.

Another issue could be with your HDMI configuration - see our article here for tips:

I’m using RetroPie 4.7.1. I used the Pi Imager to download the image and flash.

Re the HDMI config, each line is already present as below:

# uncomment if hdmi display is not detected and composite is being output

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

core_freq_min=500 is not present. 

What amendments to the script do i need to make?

You can do it using nano as described in the tutorial, or you can edit the file on a PC.

Try adding the following lines to the config:



I’ve made the changes and the system now boots but the screen goes blank immediately after the attached,. No red or green light appears on the LED

Hi Nathan,

That’s very odd that it’s working until RetroPie starts - definitely a configuration issue. Which HDMI Port is it connected to? I’d suggest trying the other HDMI port, just as a test. Note that you will need to have the HDMI cable connected before you power on the Pi.

Does this issue still occur if you remove the Pi from the NESPi case and run it externally?

I’m connected to the port next to the USB C power.

I haven’t tried removing the Pi but will tonight