RPi 4 with Argon one Pi4 stopped working

I had the Pi4 working.
I installed it into the Argon case and all was working.
Attached was a monitor, wireless keyboard and mouse and speaker via audio plug.
A printer was attached via a powered usb hub (but not turned on).
It had been working and I had used it for scanning and printing.
I had installed jriver software and was playing music via my nas music server.

I powered down, detached audio cable and plugged in a Fiio portable dac to a usb port.
When I tried to power on from the power button, nothing happened … and no lights.

I removed usd and again nothing.
I tried another power supply that was working on another pi and nothing.
I removed Argon and just attached the pi direct … again nothing.
I tried with another sd card … nothing.
Any suggestions?


It was the power cable adaptor for micro-USB to USB-C (not from Core!)

Once replaced all is back in working order.

Hey Moog,

That’s great to hear! Sorry we didn’t get back to you sooner, I was looking into this earlier but went down a bit of a rabbit hole trying to find an answer…

Thanks for this.

I ended up plugging in a hifiberry amp I had on another older pi, and verified it still worked by using that power supply.

I then checked it also with a power bank that had a usb c connection.

Then down to the local computer store and bought a new connector.

It may be worth you adding this to your memory bank.

It happened to me without any explainable reason.



1 Like

Thanks for the details!

Will do, lets hope this doesn’t have to happen to anyone else.