Sentrius LoRa Gateway

trying to get a TTN gateway working with the Sentrius. Do I need to change the radio frequencies from the defaults of the US preset?

I’m attempting to connect from a LoPy4 but it’s not finding the gateway.

Cheers Andrew

Hi Andrew,

Follow the quick start guide from Part 6 (on page 9). When you get to Part 7 (Things Network Console), choose either AU915 or AS923 (as you see fit for your community/area - both are an option in AU). If AS923; use the first option (not the second recurrence of AS923 in the list).

Update the Laird Gateway settings as noted in the instructions with your TTN settings, and it will download the channel plans (despite always showing “US” region).

thanks for this. I’m still having a struggle. The version of the quick start you link is older than the most recent on the Laird website. So the old one refers to the Things Network - US and the newer one has both this and the Things Network - US Legacy. I’ve tried both and got a connection to TTN. But the code in the tutorial is failing to get a connection and the LoPy is showing the red LED.
I’m assuming that the forwarder in the gateway setup is the Semtech one. This doesn’t seem to require the TTN Gateway key to be entered - is this the problem?

There are no moving parts besides following Part 6 & 7 in the manual, with the exception that the channel plan is changed on TTN to either AU915 or AS923.

What is your gateway ID?

If you’ve done that - the issue is more likely with the way the node is being configured and that would be worth exploring.

Hi Graham, thanks for your help. I’ve tried both AU915 and AS923 and as far as I know I have configured this right in both the TTN and Sentrius setups. Would it help to get you to log in to the TTN gateway setup and check? Or do you think it would be worth remoting in to my pc?

Hi Andrew,

What is your gateway ID - I can check a few things via the public TTN API

is this what you need? It has disconnected at present after I reset but the Sentrius says its connected. The radio frequencies on the Sentrius still read in the 900’s not the 920’s!

Sorted! Big thanks to Graham for talking me through the configs. Very pleased to be sending to TTN. Now to get stuck into the coding. Isn’t hex fun :roll_eyes:


Hi Andrew

I suspect I am having the same issues you had with the configs on the Sentrius RG191. Are you able to post a screengrab of the channel configs you modified for use with AU915 to allow nodes to connect to it? My gateway is seen by TTN but nodes can’t find it.

Sure, it won’t be until tomorrow morning though.

Hi @Heinz61139,

What is your gateway ID on TTN as shown below? Also, did you setup the Gateway with Legacy-mode enabled, or not?

No worries Andrew. Thanks for your help with this.

That’s not my gateway Graham. Mine is showing this on TTN:

I set it in Legacy Mode as shown in the Quick Start Guide below. I cannot find a way of unchecking this setting in TTN. I’d greatly appreciate knowing how to uncheck this.

I’ve just turned it back on. It’s showing on TTN.

Sorry Graham, it seems I have reached some sort of post limit on this forum, so I’m going to keep editing this post in order to talk to you. Please forgive my ignorance with LoRa as I am very new to this. With this in mind, is there any way of testing that a gateway is correctly set up without a node? I have 2 nodes set to AU915, neither of which show as connected to this gateway, even if I look at the Traffic page at the gateway ip address.

It’s certainly working on the NOC API and you are configured for AU915. Worth noting, V2 TTN has had many issues with monitoring services, however, devices/data have been humming away.

With that in mind, don’t rely on the TTN console for logs, lean to the devices themselves (and/or external data sources that TTN is pushing to).

Heinz, my gateways too are all showing as not connected in the TTN console, but have been working fine. There is obviously a problem with the TTN console display software.

As far as the Sentrius gateway config, Graham talked me through it. It seemed important NOT to use the legacy mode.

For my nodes I am using Arduino boards. Either TheThingsNetwork.h library with a RN2483 LoRa module or the LMIC library with the RFM95W radio (here use the MCCI Catena version of LMIC because it has a config file to set AU915 or AS923 frequencies).

It doesn’t really matter - just that Legacy mode will force you to use the Gateway EUI as device ID. Otherwise, you get to name it something more meaningful. Either way, it’ll work just fine (remote devices know no different).

Thanks Graham. I will continue to test the gateway on this basis.

1 Like