Raspberry Pi not booting, single red light

I recently purchased the raspberry Pi 3B and followed online tutorials to install retropie, but after following the instructions on multiple SD cards and using multiple power sources, the raspberry Pi does not boot and shows just one red light

Hi Lucas,

Hmm, that definitely looks strange. You mentioned different power sources, what is the current capacity of those? Have you tried it with the official Pi Power Supply (5V 2.5A)?

Hey, Lucas.
I might add to Sam’s suggestion, are you certain you’re using the Raspberry Pi 2/3 image from the RetroPie downloads page? (not the Raspberry Pi 0/1 image).

Yes, I also tried the NOOBS software and the recallbox software after completely formatting the ad card and still no luck.

I don’t have the official raspberry Pi power source but I have been using adapters with the recommended voltage and amps but using a USB micro USB cable, should I be using an adapter that supplies directly into the cable?

No there shouldn’t be any difference between them, as long as your supply can deliver AT LEAST 1A at 5V, then you should be ok. What sd card are you using by the way? Is it a class 10 card?

I have tried multiple sd cards all class 10 and still no luck. Is it possible there is something faulty with my Pi?

Hi Lucas,

Sounds like you’ve tried all the right things. Shoot an email through to support@coreelectronics.com.au with a link to this post and we can sort you out.

Hi Lucas,
I am new to the FORUM.
I set up a new PI3B+ last week and created my own boot mini SD also.
Had the same / similar outcome as you, single red light, Pi 7" SCREEN would just stay in rainbow display.
What i discovered is i was actually using a 64 GB card , however a 32 GB is the largest you can use for Setting up an installation/Boot/OS card.
I cant remember why, but i went back to a 32 GB and did the setup and bang, it all worked sweet.
Not sure if your problem but i thought i would mention it.


Thanks for your input Dave! I’d forgotten about the 32GB limitation. It may be too late for Lucas but maybe your feedback will help others searching for answers to the same problem!

Thanks Dave, I sent in my pi and there ended up being a fault with it.