Waveshare 7inch LCD IPS 1024×600

Hey guys,

I purchased a Waveshare 7inch LCD IPS 1024×600 from your guys last week, delivery was prompt which was great. I am having trouble getting the screen to connect to my pi 4 8gig. The screen works but only 600x400 res. I see that the website suggests that there are more steps to make this work. I have tried all these and eventually came across this Github post saying that the screen instructions haven’t been updated. But even these instructions aren’t very clear either. I am new to Pi’s but not a total new person to computers. Any help would be greatly appreciated.


1 Like

Im also having problems turning a .txt file into a no extension ssh file any assistance with this would also be great, cheers

1 Like

according to this guide on the official website I should add the following txt to the “end of config txt”

hdmi_cvt 1024 600 60 6 0 0 0

If I do it this way the unit screen boots but in 600x400

and if I do it this way the screen doesnt boot at all

Hi Edward,

Could you please confirm which version of the Raspberry Pi OS you are using and whether you are using a full or lite version (No desktop interface)? As Raspberry Pi recently went to the new major version (Bullseye) a lot of driver dependencies haven’t been sorted out yet so the Waveshare screens need different configuration depending on whether you are using Buster or Bullseye.

Regarding the extension of your SSH file, if you have your Pi on the desktop you can enable SSH via the Pi configuration menu and avoid the need to use text editors on the boot image altogether.

1 Like

Hi Trent,

This is the version I am using, I would guess that it is the latest version.


Hi Edward,

Since Bullseye launched there have been a lot of dependencies broken or missing and a lot of workarounds proposed to patch things.
I’ve just tested a display from stock with a newly-flashed, fully updated Bullseye card using a Pi 4B and it worked without changing the config.txt file at all.

I suspect that there may have been an update released which makes the modifications recommended by Waveshare unnecessary.

I’d suggest grabbing a spare SD card and flashing a new image of Bullseye, then boot up your Pi and make sure it’s up to date with:
sudo apt-get update
followed by:
sudo apt-get upgrade
Then see if your display is working correctly without further tweaks.

If you still run into issues let us know and we can dig a little deeper, but hopefully, your problem has been fixed with a software update since you first received your display.

Once we confirm your unit is working without modifications I’ll remove those config modifications from our product page.