8Bitdo M30 Bluetooth Gamepad (CE06259)

This is a placeholder topic for “8Bitdo M30 Bluetooth Gamepad” comments.

The greatest 6 button controller ever made. Redefined. 8Bitdo set out to redefine the greatest 6 button controller ever made and bring it into the modern era. they’re pleased to introduce M30.

Read more

I have set up a retropie with a Raspberry Pi 3 b+. I have connected my ME30 controllers but neither allow me to use the right trigger or the C button. I’ve updated the firmware on the controllers but I’m not sure what to try next.

Hey Dean,

I’d recommend performing an update on the Pi, by using “sudo apt-get update” and “sudo apt-get update” and if it is still not recognizing them then going from there we can try and troubleshoot for any further issues by looking for data received from the controller manually on the Pi to see whether the button pushes are being registered and ignored by the program or whether they’re not sending any signals at all in which case we will have to test it against another device. All the best with your Pi and Merry Christmas!

I’ve updated the Pi, its now running version 4.5.4. It’s still not recognising these two buttons. I’ve tried the controllers on my laptop (Java Rom). The C button works, but the Right trigger is seen as ‘Right Stick Down’. Something else I noticed was the Star button located on the left side of the three buttons below the start button doesn’t work. figured it was just for asthetics, but I thought I’d mention it any way.

Hey Dean,

First I’d recommend giving the whole controller a thorough cleaning to make sure that the buttons are being registered correctly. However, it sounds like this is a software issue on the Pi, which application in particular are you unable to use the controller on the RetroPi? Also I’m not sure if evtest will be appropriate for this kind of device but here’s a link for how to use it to read input to the Pi. All the best with your project!

Core Electronics | Support