Bluetooth issues with 8BitDo SN30pro on Rasp Pi 4 with Retropie

I’m new to RetroPie & have looked long and hard on new for a solution but no luck so far.

Bluetooth connectivity will recognize the controller sometimes as “Pro Controller” or “BBitdo SN30 Pro” or other times not at all or sometimes just as Hex string, but when I go into the security mode menu and select “DisplayYesNo” (or any other option), either nothing happens or it tells me it’s failed to pair.
It can also get hung up and the cursor is frozen, doesn’t let me select and starts imputing text at the bottom when keyboard is pressed.

When I look in Paired & Connected devices i can sometimes see the controller listed as paired but not connects, have tried connecting all devices with no luck.

This is happening on 2 separate systems and 4 different 8BitDo SN30pro controllers.

Controllers have been updated to latest firmware which is 1.36, RetroPie has been updated as well as operating system.

Can someone please help!!


Hi Richard,

I’ve done some digging and found an old forum thread that might relate to your problem!

Here’s a screencap from that thread that goes over the different modes of pairing (maybe you’re on the wrong one?)

Keen to see how you go with this!

1 Like

Hi James

Thanks for the suggestion.

I have tried pretty much all the modes w/out much luck.

When i can get a controller to appear in list to pair it (which is usually only after a fresh reboot) i have a one shot attempt to get it right, then i’ll need to reboot again to be able to see the device appear in the list of bluetooth devices to pair.

When i get to the security mode is where it hangs up, I’ve tried option 1 and now option 2 and the both just hang with system unresponsive. Device will sometimes then appear in the list of paired devices but it’s not connected and will not manually connect from the option in the menu either.


Hey Richard,

Welcome to the forum!

Also related to our conversation earlier, here are some docs on setting up wifi on RetroPie, I personally haven’t hit that issue whenever I setup RetroPie running on a Pi 4, although given that it’s occurred with all of your boards/controllers and that your install is clean and up to date suspect that it’s related to the way in which the system was setup. Sometimes it can help to run through the setup tutorials for RetoPie just to ensure that there were no steps missed through setup, I’m not sure what else we would be able to check for here, those errors don’t seem to be common from my research or experience of RetroPie with Bluetooth controllers. If anyone else has suggestions feel free to jump in :grinning_face_with_smiling_eyes:

1 Like

Hi Bryce
Thanks for the suggestion, I actually managed to fix this one. It was to do with the SSID selection as my SSID appeared in the list several times I happened to pick one higher up the list & it worked.
Thanks for your help.

1 Like

Hey Richard,

Excellent, does that occur on any other of your devices (SSID being listed multiple times)? That’s quite unusual for a Pi.

1 Like

Hi James
I think i have found the issue. It might be that the controllers don’t work with the onboard bluetooth controller.
Please have a look at these:
Retropie Freezing on Bluetooth Security Selection with 8bitdo Controller : RetroPie (
Bluetooth RetroPie Setup Script Issues - RetroPie Forum

I don’t have a USB Bluetooth adapter to try this with so I dont know if it’s the fix or not, but these two links are describing my problem perfectly.

These were purchased together as your Ultimate Retro Game Console kit, are you able to test and let me know if you can get this working?

Thanks Richard

1 Like

Hi Bryce,
Nope it’s it’s just on the Pi.
Interestingly i have 3 SSID’s one for Guest, one IoT and the main one. The Guest & IoT are shown twice (once for 2.4Ghz and once for 5Ghz) But the main SSID is shown six times!!

Very strange, both Pi’s do it exactly the same as well.

1 Like

FYI, the mode to use with a Pi is the Nintendo Switch mode. I see the forum post linked above says the opposite, but Windows mode doesn’t work for me, you need to use Switch mode and it works perfectly.

Hold Start + Y to get it into Switch mode.

Here’s a good setup tutorial video:

Just note that he runs through installing BlueMan, but that isn’t necessary - it’s an old tutorial so you can skip that step.

It’s important to note that there’s a power timeout on the controller, so you do need to go through the pairing process fairly quickly. I believe it’s only 30s with no Bluetooth connection and 15 minutes if connected, but no control input (don’t quote me on that, check the manual, but it’s something around those figures from memory).

Also, if you try to add the controller and it doesn’t pair properly, go into your list of paired devices and remove the controller before trying again - else it won’t show up in the list of available devices because it’s already been paired.

The first security option has always worked for me.


Ooooh, check out the latest video from Tim:

I have the exact same issue with the ‘Ultimate Retro Game Console’ bundle purchased this week (which arrived today).

@James @Bryce Gents,
Looks like Cameron has the same issue as me, are you guys able to test this and provide a work around?
I ordered USB Bluetooth adapters yesterday, I’m hoping these will work but need the onboard Bluetooth disabled. I’m not sure how to do this?

HI @Richard154847 and @Cameron162563 - I actually setup our RetroPie image last time we flashed them. I’m on my lonesome today as we’ve got a few staff off so it’s very busy, but I’ll see if I can get some bits together and reproduce it!

I ended up getting one of the SN30 Pro’s to work after upgrading everything via the retropie menu and then doing this as well - instantly was better : Raspberry Pi 4 won't pair to bluetooth devices - Raspberry Pi Stack Exchange

I had also connected the SSD drive USB (the cartridge slot), and there seems to be lots of interference stories online of that coupled with the active HDMI, wifi and BT (I was using a large 55" TV as the monitor - some people report lower res helps which I didn’t try), so I had also switched to ethernet and disabled wifi, tried a different HDMI port etc.

I’ve now also tried a different sd card and loaded up to try, and the pairing setup is a lot smoother. I’ll probably stick with lakka for now as FYI - but once I get that working the way I want I’ll try retropie again on the original sd card.


I received 2 of the new 8bitdo Pro 2 controllers yesterday and had the same issues pairing these. Could not find any articles yet relating directly to these controllers, but this thread seems to be the same. I tried:

  • updating firmware on both controllers
  • using setup method as shown here: 8Bitdo - RetroPie Docs
  • updating RetroPie;
  • tried setting up using each of the S.A.D.X modes (in BT pairing mode) on the controller;
    I was at times able to see the MAC address of the controller, but then the process would fail at the Security / Choose the “DisplayYesNo” section, often reporting:
An error occurred connecting to the bluetooth device     |
| (Creating device failed: org.bluez.Error.AlreadyExists:  |
| Already Exists).  

Remove Bluetooth Device / Reboot RPi and start again…

This morning I tried again using a vanilla RetroPie setup (different SDcard) and bang, I was able to get a controller paired (controller in Switch mode). This continues to pair successfully between reboots. However, following exactly the same process, I’ve been unsuccessful in pairing my second controller. :confused:

Beyond frustrating!

Also just tried the settings Cameron reported here: Raspberry Pi 4 won't pair to bluetooth devices - Raspberry Pi Stack Exchange and retrying all the setup steps again. Still can’t get the second controller to connect.

Next step is to find an external BT dongle as it seems there are a few reports out there of people having more success with those.

1 Like

Hi All,

I was able to pair both an SN30 Pro+ and a Pro 2 without issue - I’m not sure what the issue may be that you’re all facing :thinking:

The procedure I followed was:

  • Grab a preloaded RetroPie SD card from our shelf stock
  • Boot it up on a Pi 4 8GB
  • Setup a USB keyboard
  • Open up the Bluetooth configuration
  • Press and Hold Start + Y (Switch mode) and then immediately hit Enter on "Register and Connect to Bluetooth Device
  • Quickly tap down the manual to select Pro Controller, then hit Enter
  • Hit enter again on the first option - “DisplayYesNo”
  • Taken back to the Bluetooth Configuration main menu.
  • Controller is paired and immediately works to move around in the bluetooth configuration menu with the analogue sticks and dpad

Possible things that may make a difference:

  • I’ve got my controller right next to my Pi to ensure a good signal while pairing
  • I’m keeping an eye on my controller to make sure it doesn’t power down while searching for a connection/bluetooth devices
  • My controller batteries are fully charged

You can have a look at what I’m doing and the results I get here:

00:11 - removing errant BT entries (random entries sneak into the list even though never specifically selected);
00:26 - The one controller (MAC ending :33:19) that I have successfully paired (not actively paired here)
00:32 - Put 2nd controller (MAC ending :F9:1E) into BT pairing mode (+ Switch mode selected) and performing BT search;
00:56 - Found 2nd controller and selected;
00:59 - Choose DisplayYesNo
01:00 - receive error message
01:06 - note all the other BT MACs that are registered again
01:10 - and one randomly Active - I have no idea what this is, but it doesn’t stay active
01:13 - remove a heap of random BT devices
01:37 - leave the two controllers that I want registered
01:45 - turn on 2nd controller and try to “Connect” to all registered devices
01:52 - lights still blinking on controller (not connected) but Pi says it is Active
02:04 - try to add udev rule, but it says it is already there
02:11 - Display Registered devices again, and now 2nd controller not showing as Active
…try “Connect Now” and ensure 2nd controller is ON, but not in pairing mode, but it doesn’t connect
02:36 - Turn on my 1st controller to check it is still able to pair. All good.
…try to connect 2nd controller again, no go.
02:56 - remove 2nd controller from Registered list
03:00 - check that 1st controller is still active
03:13 - put 2nd controller back into pairing mode (in Switch mode) and try to search again
03:36 - Found and try to register again, and again fail when trying to select first Security option (I’ll point out here that I have also tried the second option with same failed results);
03:43 - check Registered devices and find a heap of randoms again, plus another random device saying it is Active
…remove random registered entries again
04:18 - Display Registered again - 1st Controller still active, but I can’t get the 2nd Controller to connect.


What if you remove your paired controllers and re add them?

The error you’re getting at 01:00 says it can’t pair because it’s already paired - you need to remove it if it failed to pair correctly and pair it again.

Also note that you’ve currently got your pairing mode set to background mode - so it’s constantly doing things in the background.

You shouldn’t need to manually setup a udev rule (note the error message for this one is the same) it should all be straightforward.

Sometimes the best thing to do is “turn it off and on again” - wipe your settings and start fresh.

Thanks - I have removed 2nd controller a number of times and you see me do this again at 2:56. I haven’t removed the 1st controller as it paired successfully and to be honest I’m afraid that if I remove it, it may not pair again!!!

The error at 1:00 can’t be removed, at least not from the menus. You’ll note at the start of the video I show that only the 1st controller is registered. The 2nd is not listed. However, I agree, there seems to be some remnants of it in the system.

And yes, pairing mode set to background as per some instructions, but I will try turning it off.

Setup instructions here 8Bitdo - RetroPie Docs advise to add udev rule, but I’ll see if this step can be missed (once I can get 2nd controller to pair).

I will re-format my SD card and start again with a fresh Retropie image. I’ll let you know how things go.


OK, so with a fresh Retropie image and nothing else configured (e.g. USBmount, safe shutdown script for NESPI4, wifi, ssh, roms) I was able to add both controllers and pair successfully!
Since doing getting the controllers added, I’ve now enabled ssh and added some roms. Rebooted a few times and no problems with the controllers connecting.
As @Oliver noted, I did NOT add udev rule and I left the pairing mode at default (rather than boot or background).