Creality LD-002H Firmware issues

Hi Folks,

I’ve been all over the internet recently trying to get my LD-002H resin printer (that I bought a couple years ago from Core) working with the more recent versions of Chitubox. My partner and I managed to track down the firmware from November 2021 on the site, and I’ve followed the update instructions several times in the hope that I had just missed something.

Unfortunately now, whilst the UI is great and everything else is working as expected for the update, the LCD panel isn’t showing any images. The UV backlight is working, and is most bright around the corners of the screen, which in printing produces thin film in those areas.

This sudden incapacity to show an image is obviously fatal to the process, and I’m not sure how to fix it.

The firmware in the system information is V4.4.3-x2_LCDM1 /1620x2560 /F2.21

In the top right of the UI on this screen it says “V1.0”

It has a lengthy ID tag, which I assume is like a serial number.

Very open to suggestions at this point, there’s nothing better than getting a good print and I miss it :frowning:


Hi Izzy,

Welcome to the forum!! Sorry for the delay in getting to you!

From a look around on the net, it seems like the firmware on the resin printers are a little different.

I came across this set of instructions that has worked for a few Makers:
(In regards to the LCD not showing any images it looks like they break up assests as they are loaded into the machine, this might be what happened)

Just an update - I am printing! So here’s what I did just for those of you who may have come across the same issue. (this is essentially similar to u/Tovrin’s fix but expanded for clarification)

NB - I am a Mac user

1 - I purchased a couple of San Disk 32gb USB sticks. I did not format them as they came reformatted as FAT-32.

2 - Download the latest firmware as per 3D Printer Slicer Software& Firmware Download - Creality 3D by opening the page, and clicking the “Resin Series Firmware” section and then the + to the right of LD-002H to reveal the firmware list and clicking on & downloading the firmware dated 16 nov 2021

3 - Inserted one of the new USB sticks into the computer and then open the LD-02 zip file (note that the unzipped folder is named LD-02 not LD-002)

4 - I then moved/copied the contents of the folder LD-02 (all four files - update.LCD, V3_P318…, L V4-UI…, chuangxiang…etc) to the USB and then ejected the USB once the files were copied

5 - IMPORTANT! With the PRINTER OFF - I inserted the USB stick into the printer and then switched on

6 - The printer will beep loudly several times as it processes the files on the stick

7 - The display will then come on

8 - Remove the USB and then restart the printer

9 - Insert the USB stick and then tap PRINT on the printer - you will now be able to see a list of files

10 - Tap the BIN file and tap the PLAY icon to “Print” the file

11 - Turn the printer off, and remove the USB stick

12 - Turn the printer back on again and check the firmware has been updated

(don’t try and print the CBD file from the USB - it won’t recognise it)

13 - Insert a fresh USB into your computer (or re-format the previous one) and save a file DIRECTLY from Chitubox to your USB stick - the file should save as a .ctb file

14 - Eject the USB from your computer

15 - Turn on the printer and insert the USB - you should now be able to tap Print and see names and thumbnails of your .ctb files - tap the file you want and start printing!

Hope this helps someone! Cheers!


In regards to the UV backlight not being as crisp, it sounds like it might be deteriorating - If you’d like to get back to printing with the same quality that you had originally I’d have a look at replacing it!

Unfortunately the resin printers aren’t able to interface with a PC running Pronterface or Octoprint to debug.

Let us know how you go!


I am having a similar issue. However firmware is not available on creatily website anymore, the software version i have found i tried installing. the .bin file the printer says invalid format.

Thanks James