Help with Camera HQ on Raspi 3B

I need some beginner help with my Raspi Cam HQ, that I have just received from Core.

I can use my old V2 camera module fine, if I run raspistill from commandline I get an image.

However if I

  • power off
  • unplug V2
  • plug HQ in it’s place (blue side towards USB)
  • reboot
  • run raspistill -o test.jpg from command
    I get error messages “Cannot read camera info”

I have tried following magpi HQ getting started guide but can’t see what I am doing wrong.

For the record I have tried

  • Increased gpu_mem=256
  • New power supply
  • Unplugging and replugging ribbon at each end.


Hey James,

It could be a faulty camera board - it does happen. Worth sending an email to Core, they’re pretty good at getting this stuff sorted (especially when you’ve had a decent go at some troubleshooting).

Hi James and Oliver,

Absolutely, and if you reference this forum post in an email to then we should be able to reference this to speed up the troubleshooting process. Also, do you have any other Pi or cameras to cross check this against? The more references we can have to pinpoint this problem the better. :slight_smile:

All the best!

Core Electronics | Support