Core Electronics Forum

HQ & NoIR Cameras not working on RPi 3B Bullseye - imx477 static properties missing

I recently upgraded my RPi 3+ to Bullseye and now I can’t connect to my HQ camera. I get the following when running libcamera-hello on the CLI;

libEGL warning: DRI2: failed to authenticate
[0:06:03.140450046] [1766]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3156-f4070274
[0:06:03.169470010] [1780]  WARN CameraSensorProperties camera_sensor_properties.cpp:141 No static properties available for 'imx477'
[0:06:03.169602768] [1780]  WARN CameraSensorProperties camera_sensor_properties.cpp:143 Please consider updating the camera sensor properties database
[0:06:03.286248759] [1766]  INFO Camera camera.cpp:937 configuring streams: (0) 2028x1520-YUV420
[0:06:03.286712864] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 1332x990 fmt RG10 Score: 3956.22 (best 3956.22)
[0:06:03.287040930] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 4056x3040 fmt RG12 Score: 1387 (best 1387)
[0:06:03.287143115] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 2028x1520 fmt RG12 Score: 500 (best 500)
[0:06:03.287234572] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 2028x1080 fmt RG12 Score: 1583.84 (best 500)
[0:06:03.287328424] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 1332x990 fmt pRAA Score: 3456.22 (best 500)
[0:06:03.287425661] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 4056x3040 fmt pRCC Score: 887 (best 500)
[0:06:03.287513993] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 2028x1520 fmt pRCC Score: 0 (best 0)
[0:06:03.287598054] [1780]  INFO RPI raspberrypi.cpp:122 Mode: 2028x1080 fmt pRCC Score: 1083.84 (best 0)
[0:06:03.288020024] [1780]  INFO RPI raspberrypi.cpp:620 Sensor: /base/soc/i2c0mux/i2c@1/imx477@1a - Selected mode: 2028x1520-pRCC
[0:06:03.428002193] [1780] ERROR V4L2 v4l2_videodevice.cpp:1158 /dev/video15[19:cap]: Unable to request 4 buffers: Cannot allocate memory
[0:06:03.428223073] [1780] ERROR RPI raspberrypi.cpp:817 Failed to allocate buffers

Looks like I’m missing an ‘imx477’ driver, but I’m guessing.

Any help appreciated :slight_smile:

Regards,
Jon

3 Likes

Hi Jon,

I’m not sure what’s causing that error, there have been a few things that have stopped working with Bullseye where library dependencies aren’t up to date.
Were you using a Pi 3A+ or a Pi 3B+?
Once we know what hardware you have we’ll assemble the same setup here and see if we get the same error, then work out what is broken. We’ve got a few tutorials that need updates since Bullseye launched.

2 Likes

Hi Jon,

It’s worth checking out Tim’s recent tutorial on getting your Pi HQ camera working on Bullseye - I imagine this’ll fix your issues :slight_smile:

(I believe there may be a video to go along with it before too much longer :wink: )

2 Likes

Thanks Trent - My RPi model: Raspberry Pi 3 Model B Rev 1.2
Thanks Oliver - I’ll run through this when I get the camera going.

4 Likes

Hi Jon,

I’ve hooked up a Pi 3B on the bench with a new Bullseye card and I’ve got the same error as you have with both the Pi HQ camera and the Pi NoIR camera (each gives a slightly different error).
Both of those cameras work with the Pi 4B and Bullseye using the new library functions so I’d say that a dependency is just missing for one of the drivers on the older hardware revisions.

If you want to get your camera back up and running ASAP your best bet will be to roll back to an earlier version of Raspberry Pi OS until the dependencies are patched in the new version.
You can find older versions here: Index of /raspios_armhf/images/raspios_armhf-2021-05-28

The other option is to start digging and try and find the missing dependency yourself but I suspect that way madness lies…

If we find a quick sudo dependency command which fixes it, we’ll be sure to post an update.

2 Likes

Thanks Trent,

I did go through a fair bit of googling before I came to you. Madness indeed.

I’ll revert to Buster until Bullseye gets a few patches, thanks for providing the link.

Thank you for your stellar post-sales service, I’m one happy customer.

Cheers,
Jon

3 Likes