Issue with Raspi Zero 2W

Purchased 2 x Raspberry Pi Zero 2W last week. I’ve owned Pi 1s, 3Bs and Zeros for years and this is the first time I’ve encountered this error. MicroSD cards are new 64Gb Sandisk 90MB/s units (all I could get locally).

So far, every Pi OS image I’ve tried (both 32 and 64 bit, lite and full) has resulted in the “7 blink” error message which equates to “kernal.img not found”. In every case, the bootfs partition contains a file called “kernal8.img”. (renaming it didn’t help!). I’ve also created images from both the Windows and Linux imagers with the same result.

Can any one explain what is going on here and (hopefully) suggest a solution?


1 Like

The “7 blink” error message you’re encountering on your Raspberry Pi Zero 2W indicates that the kernel image file (kernel.img) is not found during the boot process. This error typically occurs when the Raspberry Pi firmware fails to locate the necessary kernel image to initiate the operating system. I think you’ll need to rename the “kernal8.img” file to “kernel.img” on the boot partition of your SD card.

As per my initial message, I tried that numerous times with different images.

All to no avail.

Searching the web suggests it could be a corrupted image or card, so I’m going to try again with a fresh card.

Hi Alan,

The Pi Imager reads over the card after it’s done writing to make sure it matches the image, so that makes me think it’s not a bad card, but perhaps your image is corrupted?

Out of interest, what does your boot partition report as bytes used?

Have you reinstalled the Pi Imager by any chance?

This is using the 64-bit Lite version:



Happens with every microSD I have, with every image I’ve tried, whether using RasPi imager or Balena Etcher to create the image.

Most curious issue is that once I’ve tried to boot from the image in the Pi Zero 2 W, the card is no longer recognised by Windows as having a FAT bootfs image. Have tried renaming kernal8.img to kernal.img as suggested elsewhere with no result.

Both cards are about to be cast into the “some other time” drawer!

Hi James,

Still no joy.

I’ve ordered a card from the store today which will hopefully arrive on Monday or Tuesday.

If that doesn’t work, not sure what I’ll do then.


Hi Alan,

If you continue to have problems, let us know. If it looks like failed hardware, we’re happy to cover that with an RMA under warranty, however Pis are tested post-manufacture, so one failure is rare, 2 even rarer.

I found a thread suggesting that kernel8 is associated with 64-bit OSs, which can’t be run by older boards like the Zero W. I checked your store account, and I can see a recent order for 2 Zero Ws (not 2Ws), are you sure they are 2s?

FWIW I found that a 64-bit OS contained kernel8.img and the 32-bit OS had kernel.img among others.

Also couldn’t help but notice you’ve misspelled kernel a few times, so if you’re renaming files or googling things, getting that right may also help.

Could you report which kernel files are included in a freshly flashed Pi 32-bit Lite OS?


So who feels like a total goose right about now?

James advised me that I had purchased Pi Zero Ws rather than Zero 2Ws. Not sure how I did that but nevertheless, ensuring I restricted my efforts to the 32-bit version of Raspbian paid dividends.

Eventually, I was able to get a bootable system, albeit after a lot of fiddling about. Turns out that the MicroSD adapters that come with the microSD cards don’t always work…

I’ve got a box full of them and at least a third of them don’t seem to work. Good news is that the Sandisk brand seem to be most reliable.

So I’ve now got one working Pi Zero W. The other one doesn’t seem to keep the SSH password I used during the Pi Imager setup. They really need to add “Show Password” to the SSH section (they do for the wifi configuration).

Anyway, thanks to everyone who offered suggestions. It is greatly appreciated.

Now I’m just going to slink away and hide until my embarrassment fades…


1 Like

I’ve finally tried to use a Pi Zero 2 W. After several hours and attempts using multiple OS versions I proved that the Pi Imager is flawed. It failed to handle the Wi-Fi connection.

I had to put the SD card in a Pi 4 with an ethernet cable plugged in so that an IP address was assigned. I could then ssh to the Pi and that meant I could use raspi-config to configure the Wi-Fi. There was nothing to indicate that Wi-Fi had already been setup.

I then put the SD card back into the Pi Zero 2 and of course it was able to connect via Wi-Fi.

Hi John,

Just to clarify, are you trying to setup the Wi Fi settings in the imager as a custom setting or are these issues occurring on an imaged card?

I can’t say I’ve set Wi Fi up on the imager before so I can’t speak for how easy that is. I have done so on a Pi without needing an ethernet connection quite easily.

I’ve been using Pi Zero W units for many years and even last year had no problems using Imager. This is my first bad experience with Imager.

My Wi-Fi settings when using Imager today were standard. There was nothing special.

It is completely unacceptable to have to use a Pi with ethernet to configure Wi-Fi to work as it has done for years.


Hey John,

I’ve come across similar issues to this before when I was working with an Arch distro a few years back to hook-up some (fairly custom) ARM SBCs built into some bipedal soccer robots.

The issue was in how the imaging software that we had set up for deployment (which on nearly all Linux distros, Raspberry Pi OS included) had configured the wpa_supplicant configuration file which contains the network information the board attempts to connect to an available wireless AP for:


When competing overseas, it broke as the country code wasn’t being updated when we changed the network information and had to do so manually within the file whenever we hopped network info in the imager config, apparently the difference in supported channels was enough to prevent us from connecting to the local wireless network. I’d double check this is correct in the files your imager is flashing in case the localisation for the application is incorrect.

Checking your model of Pi supports both 2.4 GHz and 5 GHz wifi isn’t a bad idea either if your network only has 5 GHz up (that’s still fairly rare though, almost always both bands are up)

Unfortunately the feature allowing you to drag-drop a wpa_supplicant.conf into boot got removed in Bookworm, if you’re running Bullseye or below you can use this:

Otherwise if you’ve got a USB-MicroUSB that supports USB-OTG (On The Go) you can actually remote into your Pi over the USB connection for the initial setup to get it connected to the network, then you should be able to remote into it over the network instead. There’s a guide on this below: