Motion software on raspberry pi

The ‘motion’ software used to work on my rasp pi. However it seems to have stopped working and I have tried all possible solutions - daemon/no daemon; editing motion, motion.conf, setting permissions; etc and cannot seem to get it working at all!
The rasp pi camera does work however and I used to be able to stream video!

Hi Peter,

Sorry but you will need to be a bit more specific about the software you are trying to use, and the setup that you have with your Pi.

Have you run update/upgrade lately?

Sometimes the only solution is a fresh Raspbian image.

1 Like

what I meant was the ‘motion’ system that runs on raspberry pi:

I posted this elsewhere
noting that others have had similar issues. I cannot get it to run as a daemon or otherwise. However I do know that it used to work and now does not for some obscure reason - possibly to do with permissions. I will try one more fresh install after deleting the old version.

1 Like

Hi Peter,

It looks like you’ve got a solution via the Raspberry Pi forum!

Thanks Stephen – however I did not see a solution on the rasp pi forum?

I would like to see if anyone can get this motion s/w to work!



Mail]( for Windows 10

Hi Peter,

I realize now that those posts are from a couple weeks back. Those people who helped you out on the Pi forum are much more knowledgeable about this than I am. I’ve not used ‘motion’ before. If a fresh image, and update and upgrade of the image and motion specifically didn’t fix the problem (as suggested in the other thread) then I’m not sure what the solution might be.

Good luck with your search for answers though!

I may have fixed this issue. I went to the github source site for motion and followed the instructions to completely rebuild motion. The s/w works - at least in non daemon mode - I can stream video from the rasp pi camera!. The distribution version must have had some issue with my system.

Hi Peter. Which OS (and release) were you trying to use on the pi? (i.e. what were you installing the motion software onto?)

Just my experience with using motion (which I think is great btw) - I originally tried setting it up on my RPi a good 18 months ago and it worked for me just fine. For various reasons I ended up needing to reinstall it and found I ran into trouble and couldn’t get it to go. Looking back over my notes from the original install I found I’d used a Jessie Lite image from 2017 for the OS and then successfully installed motion on top. The second time I’d used a more recent Lite release.

When I wiped the SDcard and reinstalled using Jessie Lite I got motion working again. I’m not experienced enough to dig into what the differences were and why it didn’t work out unfortunately, but it seemed like some kind of compatibility problem between the motion binary I’d got and the version of Raspbian I was trying to use (which rebuilding from source on your Pi seems like it could well have fixed for you!)

hope your video stream’s still streaming nicely anyway

this is my software:

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION=“9 (stretch)”

I did use the instructions here:

to install motion and this seems to specify stretch but I could not get it to work.

However rebuilding from scratch using the github repository does see to work - at least for non-daemon mode at: