Raspberry Pi Zero 2 and Camera Module 3 Widew MotionEye / MotionEyeOS

Hello there,

This is my first time fiddling with RaspberryPi and wanted to go about building a single camera CCTV system.

I’d been looking into a platform called MotionEye (MotionEyeOS) and fits the bill for my needs. I’m having issues following the install instructions, I’ve run into alot of errors and warnings stating outdated packages when I’ve tried installing this over the top of Raspberry Pi OS (64bit).

I’ve had different issues when trying to use the actual OS environment installed straight onto the SD Card, where its “Unable to open video device”.

The camera is working as I’ve managed to do a libcamera-still check on RaspberryPi OS but I’m not sure other things to try.

Has anyone had any success with this platform or knows of another CCTV software/OS that can motion detect, send notifications, and record/take stills?

Any help is appreciated and please let me know if you needed any further details :smiley:

1 Like

Hi @Quinn262858

Welcome to the forums.

Sounds frustrating.
Best place to look when it seems like it’s a problem native to the OS itself is that operating systems github issues.

Maybe have a look at the solution offered on this git-issue from only a few weeks ago :slight_smile:

I found it by searching your error on the open and closed OS’s github issues page.

Wish I had more for you.
Looks like a cool project.
Pix :heavy_heart_exclamation:

1 Like

Thanks for getting back to me!

I did some more digging following on from the links which you provided, and have now got the MotionEye system running as a service on Raspbian Buster 03/05/23.

The service appears to be working however I’ve run I’m unable to open the camera by running raspistill -0 /Desktop/Image.png

I get this returned

mmal: mmal_vc_component_enable: failed to enabled component: ENOSPC
mmal: camera component couldn’t be enabled.
mmal: main: failed to create camera component.
mmal: failed to run camera app. please check for firmware updates.

I’ve run apt update, apt upgrade as well as rpi-update but none of these have worked. I’ve tried reseating the camera but this has not worked either.

Is there anything else I can try?

2 Likes

Hey @Quinn262858 - after some light research it seems like there might one of multiple possibilities.
This StackExchange post has a few people weighing in on the issue.

sanity check:
is the camera peripheral enabled from sudo raspi-config?

2 Likes

Thanks Michael,

Lot to read and try there, may even have to start from scratch, new install, the works :frowning:

sanity saving throw:
Yeah, enabled both from the raspi-config menu and the Pi Configuration Interfaces menu.

I really hope the issue isn’t hardware related - I’ll try some things this evening and see whats the go.

For what it’s worth, running rpi-update is apparently not recommended since it may ‘upgrade’ you to an unstable version of the kernal… according to a user in that StackExchange thread anyway.

I have used MotioneyeOS for a few years now. Mostly problem free. I have a couple of Pi Zero 2W boards with the Jawsper version of the software(might only work on wifi boards?). Maybe try it,or try another camera.
Best of luck.

3 Likes

Hi Andrew,

The board I currently have is the Pi Zero 2w with the camera module v3 wide.

I used the Raspberry Pi 3 image of the Jawsper build of MotionEyeOS but the camera displayed “Unable to open video device” both when I selected mmal camera and the v…something something camera.

Would you mind sharing your build specs as well as camera settings and any other steps I might be missing that weren’t documented? I’d really appreciate it.

Cheers

2 Likes

Hi Quinn,I have a very basic setup. Pi Zero 2 W board with a plain Pi camera.(MMAL camera) Using the Jawsper branch of MotioneyeOS. I add the following to the extra motion options: mmalcam_control_params -awb greyworld
to correct the negative image. That’s about it. The camera is currently in a box in my yard and not connecting to wifi due to distance.

1 Like

Hey Quinn,

Sounds like you have had a bunch of trouble with this MotionEye, it gets tricky when using it with the Raspberry Pi Zero 2 W as it is not natively supported. There are a couple of ways to get it set up including the Jawsper version, though that hasnt been updated since Jan 2022 so isnt a preffered option.

Have you had a look into the alternative software such as Shinobi? Depending on what you are doing with the camera and your plans in future with the Pi (Home automation), it may just be a better way of getting this project on its way to completion.

Cheers,
Blayden