Openlog SD card not locking in place

I have a SparkFun OpenLog unit, and I can’t seem to get a SD card to stick in the slot (i.e. the latching mechanism wont work and hold the card in the slot).

Does anyone have any suggestions on how to fix it to get a SD card to stick? All it does is the spring pushes it out again and won’t ‘click’.

Hi Andrew,

Sorry to hear you’re having trouble with your openlog. I’ve got one in front of me now to test it out, and it does lock in, although it requires a decent amount of force to push it far enough in to get it to lock. Has it only just started happening or has it been like that since you received it?

It’s been sitting in my draw for a few months unopened. I just had something I went to use it for, so pulled it out, and opened the packet for the first time. Can’t get the SD card to stick no matter how far I push in the SD card.

Hi Andrew,

You likely have - but I should ask just to be sure - have you tried another SD card?

It’s a good question. yep. tried with three, all the same results.

1 Like

Hmm, that’s frustrating, shoot an email through to with some photos of the board and what’s going on and we can help sort it out.