Problem Adding Usb Drive

Hello I have just setup my first Raspberry Pi 4 with Libreelec. All went easy except when I try to add my usb drive to library I always get the message on the main screen that my library is empty. Steps I’ve taken are Adding the usb folder as a source in File manager. It shows up as a source.

Back on home page TV Shows state my library is empty. I have highlighted TV Shows and then clicked on Enter File section then I can see the folder I setup in file manager and when i click on it it opens and I can see my TV Folder but back at main screen TV Shows still report library as empty.

I have tried right clicking on TV Show folder on usb drive and selecting scan to library - it asks to enter the TV Show name and when I do and then click OK it returns me back to enter the tv show name as if the name i am choosing is not acceptable.
I am stumped as to why my library is stating its empty. If I use my NAS everything works ok - its just with the usb drive. Its 8 Gig with 3 files approx 200mb each file. Any assistance would be greatly appreciated.
I need the TV folder to show content as I am programming it with Control4 and until Kodi recognises my TV files it wont allow me to access tv shows on USB.

Gary Sutherland

Hi Gary,

Can you post up a copy of your debug logs?

I’ve done a little bit of googling and have found a few links that might help:

A couple of quick checks are to to check your file system on your USB drive, and the file types you’re trying to add to make sure they can actually be read.

Support | Core Electronics

Hi Oliver
Thanks for your reply. I tried the suggestion (In the files view, set the content type via the context menu for the folders on the drive and then you’ll get the offer to update the library with the drives content.) and still not showing up. This is link to my debug log - Does that help or do you require the log to be posted here Thanks Gary

I’ve just taken a look too. Your USB drive is mounting fine:

1226 Apr 11 16:28:38 FITCollege udevil[569]: Mounted /dev/sda1 at /media/sda1-usb-Kingston_DataTra

Without actually knowing much about it, the smb.cnf file says you can only add sub directories of /storage. You’re trying to add a sub directory of /media. You probably just need to make sure you mount your USB drive under /storage, using mount /dev/sda1 /storage/USB

1462 # Using the following configurations as a template allows you to add
1463 # writeable shares of disks and paths under /storage
1577 [sda1-usb-Kingston_DataTra]
1578 path = /media/sda1-usb-Kingston_DataTra
1579 available = yes
1580 browseable = yes
1581 public = yes
1582 writeable = yes
1 Like