Problems with my Raspberry Pi Retropie Kit

Hi, I bought the Ultimate game console kit back in November 2018. I’ve been using it alot and it’s been pretty good. yesterday I wanted to add some more games so I deleted my N64 roms using the file browser within retropie. I then used my USB stick to transfer the new roms as I had done before with no luck, tried it again a few times and the files just weren’t popping up. I tried reformatting that USB stick and formatting another USB stick with no luck. I also noticed every time i took either USB stick from the Pi back to the PC my windows PC would report something wrong with the USB stick. I also tried to test running some normal roms just to see if the system was still working and every time i ran a rom it would present an error that there is no room to make a temp file and the rom cannot boot. At this point I was prepared to reformat the SD card and when i plugged it into my PC it is reporting my 16gb microSD card preformatted with retropie is only about 50mb total in capacity and is showing a very different file structure than what i see through the Pi file browser. I’m forced to assume at this point something has corrupted the SD card. Please let me know what I can do to fix this.


Sounds like there may be some corruption or file system error on the SD card. If you have a spare SD card grab the latest retropie image from Retropie website (Link below) and burn it onto a spare SD card.

1 Like

The Latest Retro Pi image may help to solve the issue though if you are using a Windows PC the 50mb and very different structure is not a sign of corruption The Raspberry Pi is a Linux operating systems that the way it stores information of the SD card is not compatible with windows so when you put your Pi SD card in it will give you a corrupt drive error.


Ok. So should i format the card first in windows or just reimage it?

Just reimage it with etcher it will work out all the weird file system stuff on its own.

There is a guide on using etcher on The Raspberry Pi foundation site.

Ok. I’ll give that a go. Can anyone tell me what my warranty options are in this situation?

Hi Paul,

As far as I can see you aren’t having any issues that are cause by a defect or fault within the hardware, just software. Once you re-image your SD card the problem should be fixed. This does not qualify for warranty coverage.

Let me know if you have any questions.

Fair enough. I’ll try it and report back.

I reimaged the SD card, everything booted up fine, i got my controllers set up but now when I plug in my USB sticks the pi will not install the file directory for the roms and the USB sticks are still reporting as corrupted when I plug them into my PC. I reformatted them before this and as long as they do not touch the Pi they come back fine every time. I tried different USB ports on the Pi too.
EDIT i forgot to put a ‘retropie’ folder on the USB sticks. i tested the 2nd stick after repairing it one more time and it worked fine, i copied some SNES roms and the PI accepted them and ran them. I’m testing SFTP transfer now. I’m still not sure why the first USB stick was corrupted and continues to be. I’ll clear it and test it again.


Thanks for the update Paul!