Raspberry Pi 3 Model B+ no longer boots

Hi there, my RPi 3 B+ purchased from Core in October 2018 no longer boots up. I just have the power led turned on a solid red, and nothing else happens. I have tried to leave the unit powered off for a week reading somewhere that a soft fuse could be a problem, and I have tried with and without the SD card installed, and confirm the SD card work in a different RPi I have. It was working fine then one day after a reboot decided not to come up again!

What should I try or is there anything else I can do given the unit is only 3 months old?

Thanks in advance for your help.


Hey Khurram,

Have you tried another power supply for the Pi?
If you think that there is a fault with the board send us an email through to support@coreelectronics.com.au,

Include in the email

  • A link to this thread.
  • Description of the debugging steps taken and how the fault happened. (As much detail as possible!)
  • A clear photograph of the top and bottom of the Raspberry Pi.

Thanks Clinton. I have sent the email to support.

Hopefully can get it sorted out.