Raspberry pi 4 model b not connecting to wifi after flash

no matter the operating system i flash to my raspberry pi 4 model b it refuses to connect even though the ssid and password are correct and the reigon and everything else logically checks out the only way i can connect to wifi is by doing it manually after first boot, does anyone have any ideas on a work around ?

Hi Mark,

Could you send in some photos of what you are getting. It is easy to troubleshoot these issues with visuals.

1 Like

I am a little confused.
When I flash an SD with the Pi OS and then boot the Pi 4B, I then need to enter the ssid and password.
After that it auto connects the next time I boot it and every time there after.

Is that what you are experiencing, because that is normal.
But if it does not auto connect the next time you boot then there is something in the OS not remembering the ssid and password. Or maybe there is a setting not set to auto connect. You would need to investigate the OS settings.


PS As @Jack said more info please.

Hey @Mark165529
Sounds really frustrating.

In the past a common problem I’ve experienced is root overriding my users wifi settings.
Have a look through your roots wifi settings and make sure they match up with your user wifi settings.

sudo raspi-config

(photo source)

if you change anything, don’t forget to reboot.

sudo reboot

Pix :heavy_heart_exclamation:


i tested the theory when i set up octopi server and that worked 100% fine but wether it be kali, open media vault or raspberry pi os i still run into the same issue

when i go to the above menu to manually set wifi details it keeps saying can not locate wifi.conf

1 Like

when i go to flash a new os for my pi i enter all of the details correctly but the below mentioned OS such as raspberry pi os, kali and open media vault it does not want to connect to wifi on first boot

What is the method you’re using @Mark165529 ? some description or screenshots would be helpful.

As it stands there are a few way to enter wifi credientials before the very first boot.

  • editing config.txt and/or wpa_supplicant.conf
  • using the RPi imager to preload these files with correctly formatted data

You’ve said you’ve entered the credentials but we currently don’t know which method you’re using…

i enter the details in the official raspberry pi flashing tool

Hey Mark,

Its very hard to help without a bit more information here. Is there any further info you can give us about this project that you are setting up so that we may be able to offer a bit more than just general advice?

When troubleshooting, its possible that simple fixes will work, though if they don’t seem to be, we are definitely going to need to delve a bit more here to get everything up and running as it should be for you.

Have you tried editing the config.txt and wpa_supplicant.conf files before first boot?


1 Like

I feel like we made progress here. :slight_smile:
I’d love to know the “it” that is saying wifi.conf is missing. Was this an error message on the command line? Was it a error pop up message on Kali? etc?
Could you copy and paste that error message with the stack trace?
wifi.conf is where your wifi details are encrypted and if it’s not on the PATH that’s a good target to pursue.

1 Like