Raspberry Pi 4 - USB not working

This is an observation of a problem I have had in a Pi 4 that appears to be rare but I have seen it mentioned elsewhere on the Raspberry Pi forums.

When using Noobs or Raspbian the USB ports would not work for me. Use the same SD card in another Pi 4 and all works well.

In Raspbian only once I had booted into the desktop would USB devices work (just before logging in), when booting to CLI or using NOOBS the keyboard and mouse would not work.
This meant that I could not select an OS in NOOBS to install or boot but also I could not log into Raspbian command line either, as you can imagine this poses a bit of a problem.

Anyway if you see this problem no you are not going mad.

1 Like

There is a known problem with Ubuntu and 4Gb RPi4s that the USB interface doesn’t work unless memory is restricted to 3Gb. May or may not be related to your issue.

Refer to this thread:

Hi, Thanks I have seen that issue before, it relates to 4gb RAM and an earlier version of Ubuntu. It was one of the first things I found.

In this case it is Noobs and Raspbian outside of the desktop for me that has the issue. Noobs should always work.
It could be firmware or hardware and really hard to diagnose.

Hey Chris,

Just to check quickly, even though the likelihood of all of the USB ports themselves being faulty is pretty low, can you test the USB ports to see if they’re actually receiving power?

This link should help out

Hi Owen,
The ports are working and yes power comes through however devices are not working.
For example a USB mouse does not light up however a USB keyboard the F light does come on (but does not work) so there is power.

When booting to desktop just before the login appears the mouse lights up and all is good for both keyboard and mouse.
If I booted to CLI only I could not enter a password to log in, the mouse and keyboard do not work.

This is why I suspect it is a firmware issue as USB is working but it appears only once Raspbian Desktop has started. Standard testing in Raspbian will not find a problem.

Hey again Chris,

Shoot us through an email to support@coreelectronics.com.au with these few details and some photos of the setup and we’ll try to sort it out!

Hi Owen

I already did all that with Bryce, he tested in Raspbian but not noobs from my understanding.

I was told it was a config issue with Noobs and a problem with how I set it up. Problem is it was plain old basic noobs with no changes other than the addition of WPA supplicant file and it booted just no USB. Put all the same attachments on another 4gb pi and no issue with the keyboard.

The Pi should arrive with you guys tomorrow I suspect so feel free to test it yourself. It is on its way back as a return and refund ( I really just wanted a replacement unit but anyway no matter I will buy another and more stuff for it)

Thanks Owen. I appreciate the excellent support you guys provide.

Hi Chris.

I have a Pi A+ that has a faulty USB.

The odd thing is the dongle for the wireless keyboard is the only thing that will work on it.

I have tried multiple usb devices and nothing else works, and have tried using external power on the usb, also tried different OS and makes no difference.

Sounds odd. It sounds like the USB circuit is working but something is is going on with it. Being an A for you it is different hardware.

New Pi 4 and no issues. Add the Argon neo case and it is a brilliant little machine.


I seem to have the same/similar problem. In my case, neither the mouse nor keyboard are working anymore after I updated the OS (on the recently purchased official SD Card from Core Electronics), as per Raspberry’s official website recommendation: “we no longer recommend or support using NOOBS” - https://www.raspberrypi.com/software/ . And just to advise, I purchased the (attached) components from Core Electronics within the last fortnight


Here is a short video that demonstrate’s my issue, i.e. ultimately, the mouse & keyboard inputs work when connected to my laptop, but do (not) work when I connect them to the Pi: IMG 0085 - YouTube

I am also using an upgraded Concord HDMI cable, & associated adapter, given that I experienced monitor flickering issues earlier. I called & spoke to Core Electronics Support, who advised that I try another HDMI cable.

It seems that the Pi USB port is not being powered, given that the keyboard’s LED is not luminating. However, the LED luminates when the keyboard is connected to the laptop …

I purchased this kit because it is advertised as an “educational” kit. I’m only a beginner to both electronics & programming.

Would really appreciate some tips on how to proceed.

Kind regards

1 Like

Hi Ben,

Sorry to hear it’s giving you so much trouble! I’ve got a couple ideas to troubleshoot this one before going down the RMA route:

  • Have you tried the USB3 ports? I know this seems obvious but I believe these run on a different bus, so may behave differently.
  • What does the output of dmesg look like after plugging and unplugging them? You may see some errors there that give us some insights.
  • Are you seeing any other activity on the screen? (i.e. there’s no chance it’s a video freeze)

Keen to get to the bottom of this one!


Hi James

Thanks for your support! Because my upcoming Pi projects are of a timely nature, I bought a repalacement Pi 4 yesterday, locally. Everything works fine, so far.

So, (maybe?) I short-circtuited it by not wearing gloves … But as soon as I find the time, I’ll troubleshoot your suggested steps!



command line codes to display if the rpi is seeing the device and or easy fault diagnosis if its the port or the device

will list the devices:::: that is if the ports are working and seeing the device
lsusb -t
will list all usb ports that are connected to the rpi board on board ports that is while having no devices connected…if the port is blown it will not show up in the list…

1 Like