Raspberry Pi Nano W: WLAN interface not recognised

Hi everybody,

Today I received a Raspberry Pi Nano W in the post and I’m at my wits end trying to get the WLAN to work. I thought I might have ordered the wrong board at first, but no, it’s definitely got Raspberry Pi Nano W 1.1 written on the board, and the bluetooth is working.

The issue is that I can’t seem to get Raspbian to recognize the WLAN interface at all. ifconfig -a only lists the loopback device. And if I try dmesg|grep “wlan” I get nothing at all.

So far I’ve managed to tether my Android and update/upgrade with apt, and I’ve run rpi-update which successfully updated the firmware.

I’ve been following this guide without luck: How do I set up networking/WiFi/static IP address on Raspbian/Raspberry Pi OS? - Raspberry Pi Stack Exchange
I’ve enabled SSH using raspi-config, and my /etc/wpa_supplicant/wpa_supplicant.conf looks like this:

ctrl_interface=/var/run/wpa_supplicant GROUP=netdev


I’ve also tried reinstalling with NOOBS. When that didn’t work, I tried the headless version of Stretch. And when that didn’t work, I tried Jessie. In none of them, could I get the OS to see the WLAN interface. I’m back to NOOBS and standard Stretch now.
I’ve tried only using the keyboard in case it’s a power issue, and my power supply is the official Raspberry pi one.

Seriously don’t know what I’m doing wrong here. Or could the problem be the hardware?

Any help is appreciated.

Assume you mean Raspberry Pi Zero W, not Nano.
I follow this guide and the only time it has not worked is when I forget to put ssh or wpa_supplicant.conf in the /boot directory; leave .txt on the end of wpa_supplicant.conf. or leave off .conf; or forget to put in the correct SSID and passphrase.
I examined dmesg from my latest install and it does not give much information related to setting up Wifi.
/var/log/syslog gives much more detail; other logs in that directory may help you find out what is going wrong too.


1 Like

I agree with Jim on this one. Try following the directions in the guide that he shared. I can confirm that they work. Work from a clean install just to eliminate any possible conflicts, and make sure you have run:

sudo apt-get update
sudo apt-get upgrade 

before starting

1 Like

Thanks for your suggestions. I’ve followed the instructions on that page and still no luck. I tried it headless, and when that didn’t work I plugged a monitor in to see what was going on. Nothing’s changed. This is my first raspberry pi, but I know Debian a little bit and to me it looks like Linux is not recognizing the wireless hardware at all.

I’m increasingly convinced there’s a hardware problem because if ifconfig -a isn’t even showing up wlan0 device how could wpa_supplicant even speak to it?

I also went looking through /var/log/syslog and /var/log/messages and found no obvious mention of the wireless interface either being loaded or failing. I also tried loading the module with sudo modprobe brcmfmac.

I definitely ran the following while tethered to my phone, and it successfully updated the packages and firmware:

sudo apt-get update
sudo apt-get upgrade 
sudo rpi-update

Hey Andrew,

Could you please reply to your original order confirmation email and reference this forum post?

Ok will do.


1 Like