Raspberry PI Zero W - Does it run KANO OS

Hi All,

I have a PI Zero Wireless. I am trying to get Kano OS running for my daughter. I have tried the version off the website and this version (http://dev.kano.me/public/Kanux-Beta-v2.4.0-jessie-release.img.zip) on a 32gb scandisk card. In both cases I get the rainbow screen and the device does not boot.

Anyone had success on this or can help me ??


Hey, @Matthew44089. Thanks for bringing your question to the forum.
Just letting you know that I’m imaging the card right now and will get back to you with my results.

1 Like

thank Michael appreciate your help

A fresh image of the latest (KANO OS Beta 3.10.3) just hangs at the rainbow screen. I suspect that compatibility is still only for the Zero, not the Zero W. I think the best bet would be to proceed with a Pi 3B.

ahhh damm… looks like I’ve got a useless pi z w…I’ll have a look at the pi3b on the website.
thanks very much for your help I appreciate it Michael.

any chance of trying this image ??


I’m downloading it now, but if it didn’t work with the latest image I’m quite sure the older image will be incompatible too.

That’s a negative from me. No rainbow screen but it hangs on boot.

1 Like

here’s a response from Kano on 3rd August 2017…this probably says it all.

“No, we haven’t had a chance to get a Pi Zero Wireless in the office yet and so we haven’t tested any of our releases on it.”

1 Like

Hi, don’t mean to necro an old post, but am still exactly on topic: kano on raspberry pi zero w.

I’m in the same boat, trying to get my pi0-W working with kano. So far looking fairly bleak, especially since mine is the W(ireless), not just the zero.

Been snooping around for a couple of days. It looks like they had some versions (up to 3.7, judging from youtube vids) working on the zero (not w). Now Kano seems to have completely dropped any mention of zero (original or w) on their official site. The site only offers version 3.14 for pi 2 & 3, and ver 2.1 for the pi 1. Neither works on the zero w: 3.14 hangs at rainbow screen (fails to load kernel?) and the 2.1 hangs at black screen.

I wanted to find any additional kano os kanux images, but all my searching turned up was this resource: http://dev.kano.me/public/
It does have ver. 2.2, one for the zero (with “PiZero” in the name) and one general. Both throw 2 errors on boot:

[ 0.127589] of_platfrom_populate failed: -22
[ 0199426] bcm2708-dmaengine bcm2708-dmaengine: failed to get irq for DMA channel 13

Both installs DO get past these errors and boot on my zero w, but wifi and bt are dead. Overall experience with either is slow and graphix are blurry. Couldn’t find a set of settings a la raspi-config to change much in settings that made things better (but I haven’t tinkered with it enough). The non-zero 2.2 image seems to work better (although as I write this I cannot remember specific behaviors that distinguished them off the top of my head).

The http://dev.kano.me/public/ site also has US english images going back to 3.10. Although I expected 3.10 to work as one youtuber referenced it as a zero compatible version, it also just hangs at the rainbow screen.

So, a version of Kano can work on the zero w! It would be nice to try other versions that seem to have worked on the original zero, as reported by youtubers and others, like kanux ver 3.4 and 3.7.

Although 2.2 works, I can’t give it version to my kids as is, at least until I can clean up the looks.
Then it would also be nice to avoid the errors that pop up. And add wifi… Theoretically it’s the same chip wifi/bt as the pi 3, so it should be already built it to kano.

So, if anyone has any relevant insights, please share! Specifically, I’d greatly appreciate pointers on these questions:

  • where can kano ver 3.4 - 3.7 be downloaded? could any kano owners share theirs?
  • any ideas on the errors that 2.2 throws:
    [ 0.127589] of_platfrom_populate failed: -22
    [ 0199426] bcm2708-dmaengine bcm2708-dmaengine: failed to get irq for DMA channel 13
  • any chance I could add or activate wifi/bt driver for the zero w’s built in chip in 2.2?

WIth zero w’s becoming more widely available, I would imagine and hope more of us cheapskate parents would get on this to make it work :slight_smile:


Hi Lex,

I can certainly understand the frustration. You’re addressing quite a few different points there so I’ll just hit the main ones. Unfortunately, the reason why operating systems such as Kano are mostly supported on the Model B form factor boards is that they’re a lot easier to use and provide a more streamlined experience for young makers.

Most of that is specific to Kano, and there isn’t much we can do about it, however, have you tried the build for the Pi 1? You won’t have WiFi or Bluetooth support, but it may run.

Hi Sam,

Yeap, I tried ver. 2.1 from the official site and one of the 1.3.x versions from the http://dev.kano.me/public/ page. None of those worked. Nothing shows up on the screen, the led on the pi zerro w board blinks (I think 7 or 8 short and a long blinks?).

I’m about to give up… Before I do, here’s the most current status:

  • kano 2.2 images, bot the ones designated as zero and the jessie are the only ones that boot.
    • earlier, pre-2.2 versions show no screen
    • later versions (tried ver 3.9-3.14) get stuck on the rainbow screen
    • anyone have any copies / links to versions 3.4 - 3.8 to try?
  • both 2.2 versions that run on boot throw but get past the following errors:
    "[ 0.127589] of_platfrom_populate failed: -22"
    "[ 0199426] bcm2708-dmaengine bcm2708-dmaengine: failed to get irq for DMA channel 13"
    • anyone have any idea what this means, what it affects, and if possible what can be done to prevent these?
  • the 2.2 versions do not offer wifi or bt support.
    • it is my understanding that it cannot be added since the kernel is precompiled. Is that right?




Hmm, unfortunately, it does look like a bit of a dead end. Unfortunately, my Linux foo isn’t quite strong enough to give you a definite answer (perhaps a community user will have more knowledge), however, it looks like the short answer is that Kano isn’t compatible with the Pi Zero at the moment. If you do end up finding a solution, be sure to let us know so we can spread the word.