RPi V2 Camera Troubleshooting


I have played around with raspberry pi’s for a few years (this is my 5th my 1st was a Raspberry Pi Model A) but this is the first time I have tried to connect a camera (I have taken my time :slight_smile: ). I’m working on a baby monitor with a v2 NoIR camera module on a RASPBERRY PI 3 MODEL B+ with the official Raspberry Pi power supply.

I am encountering the following error:
Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

When using raspistill -o Desktop/image.jpg

I have tried the following so far:
Changing the permissions on the Desktop folder to everyone
Rebooting the RPi several times.
Ensuring the RPi is up to date using - sudo apt-get update/upgrade and rpi-update.
Disconnecting and reconnecting the ribbon cable.
Reversing the direction of the cable.
Connecting and reconnecting the Sunny cable (when left disconnected I get a different error)
Enabling and disabling the camera using raspi-config (rebooting between changing of settings).
Re flashing the SD card with a new raspian buster image.

Using the following I get:
pi@raspberrypi-babymonitor:~ $ vcgencmd get_camera
supported=1 detected=1

I have also tried the camera unit on a different pi with a new image of raspian and get the identical issue.

I don’t have a second ribbon so I can’t try that at this stage.

Any advice will be well received and if I need to purchase another unit so be it :slight_smile:


1 Like

Hi Timothy,

Thanks for getting in touch. So that we can get your project back on track as fast as possible can we get you to run through a few more debugging steps so that we can get your project back up and running as fast as possible?

I can see that you have undertaken a lot of these steps already so there is a fair chance that the camera is faulty, but I’m also posting a full list for other users that might find this thread by Google in the future.

  • To eliminate software as a factor:

    • if using your own uSD, you should use the newest version of Noobs or Raspbian for support of new board variants.
    • If using your own uSD (not a preloaded NOOBS from us), we recommend BalenaEtcher to write the freshly downloaded image to your USD (this fixes most boot issues, due to incorrect formatting methods).
    • On a clean install of Raspberry Pi OS (Raspbian) open a terminal and try to connect to your camera using raspistill: raspistill -t 0 ​ (Ctrl-C to end the preview).
  • Run through the list of troubleshooting steps on this page: Raspberry Pi Camera Module - Raspberry Pi Documentation

I hope that information helps as we’ve discovered that returned camera issues are consistently fixed with one of the above steps.


Hi Mitchell,

Thanks you for your advice. I have tried a new clean install using the latest version (Raspberry Pi OS with desktop and recommended software, release date: January 11th 2021, kernel version: 5.4) using BalendaEtcher (with the correct checksum).

I have also run through the Raspberry Pi Camera Module - Raspberry Pi Documentation.

If you or anyone else on here has any other ideas please let me know otherwise I’ll pick up another camera (and probably another pi as you can never have too many of them :wink: )

1 Like

Hi Tim,

If you’ve bought this camera within the last 12 months it’ll still be under warranty. Just reply to your order confirmation/invoice email with some photos of how you’ve got it set up and a link to this forum topic and we’ll get it sorted for you!


Awesome, thanks excellent service