Rpi zero usb data no longer works

I ordered an rpi zero w and an rpi zero, for use as webcams.
When i received them, i flashed the sdcards with ShowMeWebcam:

This worked well, and i left the rpi’s plugged in for about an hour. When i checked on them, the webcam connection had ended on the PC, and the boards were rather warm. I tried to replug them in, but the PC did not recognise them.

I reflashed the sdcards with raspberryOS lite and plugged them in again and got no recognition from the PC, however the activity LED flashed normally. I plugged in the HDMI cable and saw the BASH login.

I did some research and saw that the PC should recognise the USB device if their is no sdcard inserted. I tried this and got no recognition from the PC.

Have i killed the USB data lines? Did ShowMeWebcam do this? I didn’t put heatsinks on the rpi’s, did they overheat and destroy USB OTG functions?

Please help, thankyou


Any help with this?

I’ve ordered another zero w.
So I’d love not to have the same issue.



Hi Nil,

It seems quite unlikely that the Pi has been damaged by overheating. Unless you’ve enabled overclocking on your board directly in order to get around thermal throttling, or the Pi is exposed to a very high ambient temp (like the inside of an oven or in exposed direct sunlight) every model of the Pi throttles its performance to drop the temperature of its components.

What I suspect may have happened here is that your most recent version of Raspberry Pi OS Lite doesn’t have the same packages installed as your original distro which was working correctly (at least initially). I suggest running through this guide I’ve linked below for you to see whether it’s possible to connect to your Pi over USB OTG as normal before trying to set up the complied ShowMeWebcam image and connect over USB OTG.


Also, running a little Stressberry test to ensure that something hasn’t gone terribly wrong with the thermistor in your board couldn’t hurt before leaving the Pi unattended:


P.S. the team over at Core Electronics can help out if you run into issues with your Pi when you receive it if we do find out there are some hardware issues. You can reply to the order confirmation email you receive to get in touch with the team there to help sort out a solution.

That being said, I’d argue that the forum is the best resource for troubleshooting as you get more of an audience for the problem, there’s always people online (including staff members), it helps the community as anyone running into similar issues can read this to find solutions, and it’s much easier to shoot through resources such as videos and photos as needed :grinning_face_with_smiling_eyes:


Thanks Bryce.

The OTG setup is what I’ve been trying to achieve, but the device is never recognised by a PC.
I wish I could try the stress test, but I can’t get internet on the zero(sans w).

I tried it all again tonight and the zero got so hot it burnt my fingers. :fire::vulcan_salute:
I won’t power it again, as it is a fire hazard now.
From my research, it appears the board is classified as “dead”. I still have no idea how this has happened.

I’ll try replying to the order email.
Thanks again.


No worries Nil,

The team should be getting back to you very soon. It sounds like there’s been some kind of failure with the Pi if it is getting higher than 85C, either through an issue with the OS or the internal thermistor, causing the board not to throttle the chip and overheat.

I agree, likely best not to use it especially unattended. QC for Raspberry Pi is quite impressive so if this is a hardware failure or fault, I highly doubt it would happen twice unless something else is going on in the setup. Let us know from here once you’ve got your new Pi and what you’re doing to set it up and we’ll see what we can do to help you out from here!

Enjoy your day!