Trouble getting Raspberry Pi Camera v2 Working

I’ve recently got hold of Core Electronics Raspberry Pi Zero W and Camera V2 package, but am having trouble getting the camera to work.

I’ve got the Pi Zero W connected to wifi and am connecting successfully over SSH.

I’ve run:

  • sudo apt-get update
  • sudo apt-get upgrade
  • sudo raspi-config - and then enabled the camera, and rebooted
    I have a 1A psu which I’ve read should be sufficient for the Pi Zero (with no keyboard or mouse)
    I have checked and rechecked that the cable connecting the camera is aligned and clamped in.
    But when I run ‘raspistill -v -o test.jpg’ I get the following message:

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn’t be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

I tried the camera on a Pi 3 too, with the same result. Have I missed anything obvious here?
Any ideas on what I could try next?


Hi Steve,

Hmm, it does sound a little strange. So you’ve checked for the alignment on the ribbon cable? Could you shoot through a picture of your setup?

Hi Sam,
Yes I’ve checked the cable and re-inserted it several times. My setup is
quite simple as I’m connecting to the Pi Zero over wifi/ssh.
Here’s a couple of pictures. Can you confirm the cable is the right way
around? I’m 95% certain it’s right…

Thanks for that Michael, I tried the firmware upgrade as you suggested, which seemed to work ok (no errors!), but after the reboot I get the same error as before.

Hi Stephen,

It looks like there may be an issue with your camera board. Can you reply to your order confirmation email with a link to this forum post and we can get that underway for you.