Pi camera v2 not working

running pi3 , have done firmware and software updates, v1 cameras work, tried different cables, and checking connectors, just get the following error

mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
Traceback (most recent call last):
  File "cam.py", line 4, in <module>
camera = PiCamera()
  File "/usr/lib/python2.7/dist-packages/picamera/camera.py", line 431, in __init__
self._init_camera(camera_num, stereo_mode, stereo_decimate)
  File "/usr/lib/python2.7/dist-packages/picamera/camera.py", line 460, in _init_camera
"Camera is not enabled. Try running 'sudo raspi-config' "
picamera.exc.PiCameraError: Camera is not enabled. Try running 'sudo raspi-config' and ensure that the camera has been enabled.

(program exited with code: 1)
Press return to continue

Hi @Hayden634,
Just to make sure we’re talking about the same thing, and for anybody else who may read this - you have executed the following:

sudo apt-get update && sudo apt-get upgrade`
sudo apt-get dist-upgrade
sudo rpi-update

Is that correct?

In this thread, some people had success reimaging the SD card entirely when encountering the ENOMEM error.

got it working ! we where talking about the same thing, but i ran the commands again just to be sure., all did nothing (as already up to date except sudo apt-get upgrade which grabbed some firmware’s i noticed. anyway after reboot its working. great !

1 Like

i spoke too soon, now its not again… will have to keep trying

so i still couldnt get it going, even tried a fresh sd, updated it as you suggest. v2 camera doesnt work but v1 does…

Hi Hayden,

To confirm, you have a fresh NOOBS image and have updated it with the commands Michael shared above? I ask as freshly downloaded + updated NOOBS has certainly solved similar issues in the past.

Also, are you running some very vanilla script such as (if not, then open a new file and save it as camera.py. It’s important that you do not save it as picamera.py):

from picamera import PiCamera
from time import sleep

camera = PiCamera()


so i just ran the commands again (on a fresh install) to show that id done them and get the error code, and i got a still !! will see if i can get anymore and video

pi@raspberrypi:~ $ sudo apt-get update && sudo apt-get upgrade
Get:1 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Get:2 http://archive.raspberrypi.org jessie InRelease [22.9 kB]                        
Get:3 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,535 kB]
Hit http://archive.raspberrypi.org jessie/main armhf Packages        
Hit http://archive.raspberrypi.org jessie/ui armhf Packages                                              
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB                                                                                                                                                                             
Get:4 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3 kB]                                                                                                                                                             
Get:5 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [84.2 kB]                                                                                                                                                            
Ign http://archive.raspberrypi.org jessie/main Translation-en                                                                                                                                                                                
Get:6 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]                                                                                                                                                                 
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB                                                                                                                                                                               
Ign http://archive.raspberrypi.org jessie/ui Translation-en                                                                                                                                                                                  
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB                                                                                                                                                                      
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,702 kB in 38s (249 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@raspberrypi:~ $ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@raspberrypi:~ $ sudo rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Your firmware is already up to date
pi@raspberrypi:~ $ raspistill -o image.jpg
pi@raspberrypi:~ $
1 Like

Neat, my fingers are cross for you!

man, it was working nice, even on my original sd card system. then i just moved it to my other desk and now its not working again…

I know you mentioned you checked connections earlier, but there’s one easily missed which is the SUNNY connector that connects the camera module to the PCB.
Here’s an image of the connector.

If this connector isn’t seated correctly then I can see how that would intermittently throw an error.

did mean i did that.

1 Like

If the only change is movement; then I am certain there is something up with either a connector (be it Pi, or one of the two on the camera) or the camera cable. Did you have a spare cable or camera to half-split the situation; you could send the camera to us if you’d like us to test for you?

i have several cables, and 2 other v1 cameras, i have no troubles with them, and can take the not working v2 off, and put a v1 on and it works right away, or after reboot, i think im out of options but to send it back, though i will likely just try one more time…

So finally got around to testing out the new v2 board replacement sent , but it doesnt work. i just keep getting this error:

picamera.exc.PiCameraRuntimeError: No data recevied from sensor. Check all connections, including the SUNNY chip on the camera board

have checked connections, and updates, v1 board works but v2 doesnt

Hi Hayden,

So the replacement you received is showing the exact same type of error?

no not the same error exactly. the other one worked rarely. this one never.
raspistill -o cam.jpg
mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

Hmm ok. Well, with the Raspberry Pi quality control, it’s almost impossible to get two faulty boards, even one is a rarity. It might be that the issue is on your Raspberry Pi board at the connector.

Yet i have a v1 board connected, it works, i power off, i take the camera off leaving cable behind, attach v2 camera, it doesnt work

Yep. The best way forward would be to grab another Pi board and everything should work given you’ve got a new camera board. Have you tried changing the cable itself?